Topic
  • 2 replies
  • Latest Post - ‏2013-02-07T18:26:57Z by Tom_McManus
Tom_McManus
Tom_McManus
8 Posts

Pinned topic Is com/ibm/websphere/rsadapter/WSCallHelper available with Liberty?

‏2013-02-07T16:41:21Z |
I have an ISV porting from WAS Base to Liberty. We are running into the following when running their code. I am assuming that they have com/ibm/websphere/rsadapter/WSCallHelper in one of their get connection methods. I have a query into them for the code. Is there something similar that is portable between Liberty and WAS Base?

Current feature list:
<featureManager>
<feature>servlet-3.0</feature>
<feature>jsp-2.2</feature>
<feature>jndi-1.0</feature>
<feature>jdbc-4.0</feature>
</featureManager>

ERROR Uncaught.init.exception.thrown.by.servlet TAInit myapp java.lang.NoClassDefFoundError: com/ibm/websphere/rsadapter/WSCallHelper

thanks,
Tom McManus
  • SystemAdmin
    SystemAdmin
    590 Posts

    Re: Is com/ibm/websphere/rsadapter/WSCallHelper available with Liberty?

    ‏2013-02-07T18:05:32Z  
    hi,

    None of our IBM specific interfaces for JDBC are available in Liberty at this time. Please note that JDBC4.0 is supported with Liberty and if you are trying to call an vendor specific interface then you can use the wrapper feature of the JDBC4.0 to get to the underlying Object and call the method directly on it.

    Hope that helps !!!
  • Tom_McManus
    Tom_McManus
    8 Posts

    Re: Is com/ibm/websphere/rsadapter/WSCallHelper available with Liberty?

    ‏2013-02-07T18:26:57Z  
    Thanks Soloman.