Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2013-01-05T05:20:22Z by SystemAdmin
SystemAdmin
SystemAdmin
8614 Posts
ACCEPTED ANSWER

Pinned topic Error in Massload utiltiy

‏2013-01-03T07:46:44Z |
I am trying to load the attachment target and attachment asset using massload. I am getting error while generating using idresgen saying member_id is unresolved.The code below i used to load.can anyone pls help to solve it.Thanks in advance

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE import SYSTEM "../schema/xml/wcs.dtd">
<import>
<orgentity orgentity_id="@orgentity_1" orgentityname="Madisons2 Organization" orgentitytype="O" > <ISA>
<member type="O" state="1" />
</ISA>
</orgentity>
<store store_id="@store_id" directory="Al Futtaim Group" storegrp_id="-1" />
<catentry catentry_id="@catentry_id_1" partnumber="Bodysuit-Black-Petit" member_id="@member_id" catenttype_id="ItemBean" markfordelete="0" />
<atchtgt atchtgt_id="@atchtgt_Attachmentcode_1" storeent_id="&store_id;" member_id="@member_id" identifier="Attach1" />
<atchast atchast_id="@atchast_MyFiles_1" storeent_id="&store_id;" atchtgt_id="@atchtgt_Attachmentcode_1" atchastpath="Attachment/MyFiles1/Image1" directorypath="Attachment/MyFiles1" />
<atchastlg atchastlg_id="@atchastlg_1" atchast_id="@atchast_MyFiles_1" language_id="-1" />
<atchtgtdsc atchtgtdsc_id="@atchtgtdsc_id_1" atchtgt_id="@atchtgt_Attachmentcode_1" language_id="-1" name="Attach1" shortdescription="Attachmentcode11 short desc" longdescription="Attachmentcode1 long desc" />
<atchrel atchrel_id="@atchrel_id_1" object_id="@catentry_id_1" atchobjtyp_id="3" atchtgt_id="@atchtgt_Attachmentcode_1" atchrlus_id="1" />

</import>
Updated on 2013-01-05T05:20:22Z at 2013-01-05T05:20:22Z by SystemAdmin
  • HariHaran
    HariHaran
    34 Posts
    ACCEPTED ANSWER

    Re: Error in Massload utiltiy

    ‏2013-01-04T02:48:59Z  in response to SystemAdmin
    Have you tried setting the DN value for the orgentity , with that set it should be able to resolve the member id of Org.
    • SystemAdmin
      SystemAdmin
      8614 Posts
      ACCEPTED ANSWER

      Re: Error in Massload utiltiy

      ‏2013-01-05T05:20:22Z  in response to HariHaran
      The member id is resolved for orgentity and member table based on the orgentity name.It is generated in the output file of idresgen also. It is not resolved only in catentry and atchtgt tables.The catentry and atchtgt tables are not able to use the member_id which is generated in orgentity and member table.how to resolve this?