Topic
5 replies Latest Post - ‏2012-10-04T11:18:36Z by JMW98
BanduPrasad
BanduPrasad
3 Posts
ACCEPTED ANSWER

Pinned topic On loading the website the page redirects to a different theme?

‏2012-09-27T09:13:50Z |
HI,
We are facing an issue with the Page loading. The home page doesnt gets laoded when the site is accessed through the browser. The non-default theme gets loaded and a different pages gets lkoaded.

We are also not able to access the IBM WebSphere Console for creation of the pages. IT redirects to this error page and hkeeps re loading automatically.

Our architect involves a Cache Server -> HTTP Server -> Portal Server -> WCM Server

Any one had faced such scenario earlier..?
Updated on 2012-10-04T11:18:36Z at 2012-10-04T11:18:36Z by JMW98
  • JMW98
    JMW98
    1074 Posts
    ACCEPTED ANSWER

    Re: On loading the website the page redirects to a different theme?

    ‏2012-09-27T19:24:34Z  in response to BanduPrasad
    Make sure the default authenticated/unauthenticated page is what you expect to be the "home" page:

    http://www-01.ibm.com/support/docview.wss?uid=swg21381183

    Inspect the cookies and make sure WASReqURL is not playing a role. You can generally filter out any WASReqURL-related problems per:

    http://www-01.ibm.com/support/docview.wss?uid=swg1PM19405

    For the console problem, are you requesting .../wps/myportal/Administration? Sometimes duplicate URL mappings / friendly URLs can cause loops like this. Check Export.xml/XMLAccess output for any such duplicates.
  • BanduPrasad
    BanduPrasad
    3 Posts
    ACCEPTED ANSWER

    Re: On loading the website the page redirects to a different theme?

    ‏2012-09-28T10:52:12Z  in response to BanduPrasad
    Hi,

    Thanks for responding. We checked the links provided by you. The "Home" page is on the top of the list of pages when we click on Manage Pages link. It looks similar to what is displayed in the link provided.

    We had tested by moving Login portal page upwards in the list and it works fine when the http:/ /portalserver.com/wps/portal link is accessed.

    We have issue only with the Home page which is created. This page was working fine since 2 years. Only from Monday we started getting the issue.

    Regards,
    bandu
    • JMW98
      JMW98
      1074 Posts
      ACCEPTED ANSWER

      Re: On loading the website the page redirects to a different theme?

      ‏2012-10-01T13:07:11Z  in response to BanduPrasad
      Did you check for duplicate or conflicting URL mappings / Friendly URLs? You could open a PMR to trace this through, if needed.
  • BanduPrasad
    BanduPrasad
    3 Posts
    ACCEPTED ANSWER

    Re: On loading the website the page redirects to a different theme?

    ‏2012-10-04T08:13:59Z  in response to BanduPrasad
    Hi,

    Since we are not able to access the Login Portlet, we are unable to find out if there are duplicate entries for URL mapping. Is there a way to find out that from unix console?
    • JMW98
      JMW98
      1074 Posts
      ACCEPTED ANSWER

      Re: On loading the website the page redirects to a different theme?

      ‏2012-10-04T11:18:36Z  in response to BanduPrasad
      Maybe you could log in with the automatic login URL:
      http://server:port/wps/portal/cxml/04_SD9ePMtCP1I800I_KydQvyHFUBADPmuQy?userid=userid&password=password

      Or you could review ExportRelease.xml/XMLAccess output for friendly URL / URL mapping conflicts.