Topic
11 replies Latest Post - ‏2013-02-08T07:38:36Z by SystemAdmin
vikrantislav
vikrantislav
40 Posts
ACCEPTED ANSWER

Pinned topic error installing Server in 3.1.1

‏2012-04-30T21:14:37Z |
i'm trying to install a WASCE 3.0 server adapter and get this error:

Cannot complete the install because one or more required items could not be found.
Software being installed: WASCE v3.0 Server Adapter Assembly 3.0.0 (com.ibm.wasce.v30.feature.feature.group 3.0.0)
Missing requirement: WASCE v3.0 Server Adapter Assembly 3.0.0 (com.ibm.wasce.v30.feature.feature.group 3.0.0) requires 'org.eclipse.jst.server_ui.feature.feature.group 3.2.0.v201005241530' but it could not be found

I get a similar error for any other server adapter as well. Previously in DS 3.1 under Define a New Server, there was a selection of server adapters available by default but they are not present in 3.1.1. So i went to Download Additional Server Adapters and got this error.
Updated on 2013-02-08T07:38:36Z at 2013-02-08T07:38:36Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1632 Posts
    ACCEPTED ANSWER

    Re: error installing Server in 3.1.1

    ‏2012-05-09T16:09:16Z  in response to vikrantislav
    I get the same error. Are you using RAD or standard Eclipse?
    • vikrantislav
      vikrantislav
      40 Posts
      ACCEPTED ANSWER

      Re: error installing Server in 3.1.1

      ‏2012-05-09T17:29:49Z  in response to SystemAdmin
      i'm using Data Studio 3.1.1 Full Client installed from IBM Installation Manager
      • David.Zhu
        David.Zhu
        66 Posts
        ACCEPTED ANSWER

        Re: error installing Server in 3.1.1

        ‏2012-05-11T06:35:07Z  in response to vikrantislav
        You can try following steps.
        1. Open the "Help->Install new software...".,
        2. In the dialog, check the checkbox "contact all update sties during install to find all required software"
        3. Click the link "Available software site", in the site list,check the site "http://download.eclipse.org/release/helios".
        4.Install WAS CE 3.0 as before, it will automtacilly find the dependence for you.

        David
        Data Studio Developer
        • SystemAdmin
          SystemAdmin
          1632 Posts
          ACCEPTED ANSWER

          Re: error installing Server in 3.1.1

          ‏2012-05-11T14:54:35Z  in response to David.Zhu
          Unfortunately, this doesn't work on RAD 8.0.4
          • David.Zhu
            David.Zhu
            66 Posts
            ACCEPTED ANSWER

            Re: error installing Server in 3.1.1

            ‏2012-05-11T16:50:01Z  in response to SystemAdmin
            It should be "Download and install support for a new server" mechanism which doesn't support automatically dependency check. But though you install fail, it should already add a site in the "Available software site" You can install from "Help -> Install new software" and choose the site "update site: http://public.dhe.ibm.com/software/websphere/wasce/updates/", it should work now.

            For safety, you can load the helios component list firstly through "Help -> Install new software". In the "Work with" combox select "Helios - http://download.eclipse.org/release/helios". After all components show in the text field, you can then choose WAS CE 3.0 URL to install WAS CE 3.0.
            • SystemAdmin
              SystemAdmin
              1632 Posts
              ACCEPTED ANSWER

              Re: error installing Server in 3.1.1

              ‏2012-05-14T12:01:12Z  in response to David.Zhu
              It does not work. I have installed a clean RAD 8.0.4.1 and enabled the only following two repositories:

              http://download.eclipse.org/releases/helios
              http://public.dhe.ibm.com/software/websphere/wasce/updates/

              If I try to add the server adapter through "Window-Preferences-Server-Runtime Environment (Download additional adapters)", or through "Help-Install New Software" I get the following error in both cases:

              Cannot complete the install because one or more required items could not be found.
              Software currently installed: WASCE v3.0 Server Adapter Assembly 3.0.0 (com.ibm.wasce.v30.feature.feature.group 3.0.0)
              Missing requirement: Geronimo Server Tools V30 UI Plug-in 3.0.0 (org.apache.geronimo.st.v30.ui 3.0.0) requires 'bundle org.eclipse.tm.terminal.view [2.1.0,4.0.0)' but it could not be found
              Cannot satisfy dependency:
              From: WASCE v3.0 Server Adapter Assembly 3.0.0 (com.ibm.wasce.v30.feature.feature.group 3.0.0)
              To: org.apache.geronimo.st.v30.ui http://3.0.0
              Is there any way to install the missing elements ahead of time?
              • David.Zhu
                David.Zhu
                66 Posts
                ACCEPTED ANSWER

                Re: error installing Server in 3.1.1

                ‏2012-05-15T14:08:20Z  in response to SystemAdmin
                Ok, I verify that method on Data Studio and it can work. but the way to make it work in RAD is same. You can add the site which include the missing feature. According to your error message, you can add "geronimo" related site through "install server" dialog same with you add WASCE site and then install WASCE from install new software wizard.
                • SystemAdmin
                  SystemAdmin
                  1632 Posts
                  ACCEPTED ANSWER

                  Re: error installing Server in 3.1.1

                  ‏2012-05-16T08:36:04Z  in response to David.Zhu
                  I have tried adding all available Geronimo sites with no luck. Has ANYBODY had any luck with RAD 8.0.4 and WASCE 3.0.0 adapter??
                  • SystemAdmin
                    SystemAdmin
                    1632 Posts
                    ACCEPTED ANSWER

                    Re: error installing Server in 3.1.1

                    ‏2012-07-09T18:17:36Z  in response to SystemAdmin
                    1. Enable update site: http://download.eclipse.org/dsdp/tm/updates/3.2
                    2. Select Expand TM and RSE Uncategorized 3.2.2 and select the Target Management Terminal option
                    3. Restart, and then try reinstalling the adapter
                    Good to go after that.