Topic
2 replies Latest Post - ‏2013-08-05T17:13:32Z by Ricardo_Cartes
SystemAdmin
SystemAdmin
15496 Posts
ACCEPTED ANSWER

Pinned topic Cognos Developer Edition 10 Installation on win7 64bit problems

‏2011-11-27T00:46:15Z |
I just downloaded the installer using DownloadDirector, CZS56EN.tar.gz Release notes shows 10.1.0

First, running install.exe from the downloaded folder and the installer default directory c:\Program Files(x86)\Cognos Developer

This failed to install the Content Database. I uninstalled and ran it again as administrator...no change.

Lastly, I uninstalled and ran it again changing the install directory to c:\IBM\Cognos Developer\ This time it failed to start the Derby, but the installation completed.

I see NOTHING IN THE START MENU for Cognos so nothing to comply with "After the installation wizard finishes, you can launch IBM Cognos BI Developer Edition Manager.
The manager allows you to install, configure, and start the IBM Cognos BI services, and install
Framework Manager."

Looking in the Services Control panel, I see the service "IBM Cognos BI Developer Edition:9300" Started Automatic, but the IBM Cognos Content Database is not started and tried to start it and got, "The IBM Cognos Content Database Service on Local Computer started then stopped. Some service stop automatically if they are not in use by other services or programs."

http://localhost:9300 gives nothing on Chrome, FF or IE

cbs_start.log

Sun Nov 27 07:28:46 2011 INFO t2964 CBSNTService Attempt to starting service "IBM Cognos BI Developer Edition:9300"
Sun Nov 27 07:28:46 2011 INFO t2964 CBSNTService Starting service "IBM Cognos BI Developer Edition:9300"
Sun Nov 27 07:28:47 2011 INFO t2964 CBSNTService Waiting for service to start...
Sun Nov 27 07:29:55 2011 INFO t2964 CBSNTService Started service "IBM Cognos BI Developer Edition:9300"

Sun Nov 27 07:29:55 2011 FATAL t2964 CBSCryptoHelper failed to initialize crypto.
Sun Nov 27 07:29:55 2011 INFO t2964 CBSBootstrapService attempt to load config from "C:\IBM\Cognos Developer\bin\./bootstrap_win32.xml"
Sun Nov 27 07:29:55 2011 ERROR t2964 CBSChildProcess exception while checking for the dependent component version: ""
Sun Nov 27 07:29:55 2011 INFO t2964 CBSBootstrapService testReadyByPingingWin - pinged all children successfully.
Sun Nov 27 07:29:55 2011 FATAL t2964 CBSCryptoHelper CAM_CryptoTerminate failed, return code: -1
Sun Nov 27 07:29:55 2011 FATAL t2964 CBSCryptoHelper CAM_CryptoTerminate failed, CAM error details:

cbs_run.log

Sun Nov 27 07:36:06 2011 FATAL tac4 CBSCryptoHelper failed to initialize crypto.
Sun Nov 27 07:36:06 2011 INFO tac4 CBSBootstrapService attempt to load config from "./bootstrap_win32.xml"
Sun Nov 27 07:36:06 2011 ERROR tac4 CBSChildProcess exception while checking for the dependent component version: ""
Sun Nov 27 07:36:11 2011 INFO tac4 CBSBootstrapService IBM Cognos Bootstrap Service running as process 2492.
Sun Nov 27 07:37:12 2011 INFO tac4 CBSBootstrapService CBSBootstrapService::Run() - child process(es) is/are ready.
Sun Nov 27 07:37:12 2011 INFO tac4 CBSServiceStatusUpdater interrupt, final status is 4
Sun Nov 27 07:37:12 2011 INFO tac8 CBSServiceStatusUpdater ending, final status is 4

derby.log


2011-11-26 23:29:56.124 GMT:
Booting Derby version The Apache Software Foundation - Apache Derby - 10.1.2.1 - (330608): instance c013800d-0133-e236-b580-00003f4813d6
on database directory C:\IBM\Cognos Developer\contentstore\cm

Database Class Loader started - derby.database.classpath=''

2011-11-26 23:29:56.833 GMT:
Shutting down instance c013800d-0133-e236-b580-00003f4813d6


cbs_default.log

Sun Nov 27 07:28:46 2011 INFO t26cc CBSBootstrapService reinstalling service "IBM Cognos BI Developer Edition:9300".
Sun Nov 27 07:28:46 2011 INFO t26cc CBSBootstrapService Installing...
Sun Nov 27 07:28:46 2011 INFO t26cc CBSBootstrapService renstalled successfully.
Port Scanner does NOT show 9300, nor does firewall show the cognos tomcat running or requesting a port.

What do I need to do to get this running?
Updated on 2013-02-16T15:12:28Z at 2013-02-16T15:12:28Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    15496 Posts
    ACCEPTED ANSWER

    Re: Cognos Developer Edition 10 Installation on win7 64bit problems

    ‏2013-02-16T15:12:28Z  in response to SystemAdmin
    Did you ever resolve this issue? I'm getting the
    "Database Class Loader started - derby.database.classpath="
    message as well...
    • Ricardo_Cartes
      Ricardo_Cartes
      2 Posts
      ACCEPTED ANSWER

      Re: Cognos Developer Edition 10 Installation on win7 64bit problems

      ‏2013-08-05T17:13:32Z  in response to SystemAdmin
      I had the same problem, I solved it by setting the environment varible DERBY_HOME as in my Windows OS.
      something like as what comes out in the attached image

      Attachments