Topic
3 replies Latest Post - ‏2012-12-14T13:57:48Z by SystemAdmin
loco_mx
loco_mx
1 Post
ACCEPTED ANSWER

Pinned topic Problem with a VG on one Disk

‏2010-01-13T11:55:21Z |
Hi, i realy need you help with this problem.

I can´t import the VG.

zeta /home/root # importvg -y vgcordb_cert hdiskpower31
0516-022 : Illegal parameter or structure value.
0516-780 importvg: Unable to import volume group from hdiskpower31.

I have this problem on the past like this with a similar CLARiiON and the way that i take i was this.

recreatevg -y vgname hdiskpowerxx hdiskpowerxx
synclvodm -v -P vgname

But in this case it´s not working. This disk´s dont have a PVID and it was difrent on the VGDA
On the hdiskpower31 it´s difrent of the other two disk. And the name of the LV have two difrnte letters.

zeta /home/root # lqueryvg -Atp /dev/hdiskpower31
0516-304 lqueryvg: Unable to find device id hdiskpower31 in the Device
Configuration Database.
Logical 002544fa00004c0000000112c0879435.1 lvcordb01 1
002544fa00004c0000000112c0879435.2 lvcorapli 1
002544fa00004c0000000112c0879435.3 loglv04 1
Physical 002544fac398dba7 1 0
002544fac39e31c6 1 0
002544fac3a5748b 1 0

zeta /home/root # lqueryvg -Atp /dev/hdiskpower32
0516-304 lqueryvg: Unable to find device id hdiskpower32 in the Device
Configuration Database.
Logical 0023f68b00004c0000000126256dfb3e.1 fslvcordb01 1
0023f68b00004c0000000126256dfb3e.2 fslvcorapli 1
0023f68b00004c0000000126256dfb3e.3 fsloglv04 1
Physical 002544fac398dba7 1 0
0023f68b34aae4a8 1 0
0023f68b34ab3fdb 1 0

zeta /home/root # lqueryvg -Atp /dev/hdiskpower33
0516-304 lqueryvg: Unable to find device id hdiskpower33 in the Device
Configuration Database.
Logical 0023f68b00004c0000000126256dfb3e.1 fslvcordb01 1
0023f68b00004c0000000126256dfb3e.2 fslvcorapli 1
0023f68b00004c0000000126256dfb3e.3 fsloglv04 1
Physical 002544fac398dba7 1 0
0023f68b34aae4a8 1 0
0023f68b34ab3fdb 1 0
I realy need know, how can i recover this VG.
Updated on 2012-12-14T13:57:48Z at 2012-12-14T13:57:48Z by SystemAdmin
  • Najam Kazi
    Najam Kazi
    9 Posts
    ACCEPTED ANSWER

    Re: Problem with a VG on one Disk

    ‏2010-01-13T14:50:39Z  in response to loco_mx
    Try with '

    importvg -y 'vgcordb_cert' hdiskpower31
    else try to give a major number with the vg
    importvg -y 'vgcordb_cert' -V '70' hdiskpower31
    Sometimes missing silly things like this AIX doesn't do what we intend to do.

    najam kazi
    • Najam Kazi
      Najam Kazi
      9 Posts
      ACCEPTED ANSWER

      Re: Problem with a VG on one Disk

      ‏2010-01-13T14:54:30Z  in response to Najam Kazi
      Also do you have record of vgs adn pvids when you exported them, because you might be importing on wrong disk. Don't know about EMC, we have IPSTOR, so for MPIO we use dynapath, if the MPIO tool is not started, the disk doesn't allow to work on it. If you have lost your pvid, worry not, you can spoof a pvid on a disk and impirtvg, if you have records of the info. You might have to run fsck on lv after this butis much faster than restore.

      Good luck
      Najam kazi
  • SystemAdmin
    SystemAdmin
    6907 Posts
    ACCEPTED ANSWER

    Re: Problem with a VG on one Disk

    ‏2012-12-14T13:57:48Z  in response to loco_mx
    its simple.

    just use this command

    1. recreatevg -y newvg hdisk1