Comments (6)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 Long Xiang ZHU commented Permalink

good sharing,thanks

2 KateDawson commented Permalink

Thanks for your comment! We'll continue to post DB2 Tech Tips in 2012, so keep visiting the blog to learn more.

3 vijayharish commented Permalink

whether i need to reinstall the db2 after the changes made in the groups. please help me..the problem is still not solved in my case.

4 commented Permalink

We followed the instructions in the tech doc and are still getting the error. Do you have any other suggestions?

5 minhtandtu commented Permalink

In order to solving this problem, run it as Administrator

6 9W1M_Birender_Saini commented Permalink

I looked and looked, followed advice on this arcticle and some comment suggestions below but what ultimately worked for me is just so silly (and not what is mentioned in the article). I registered just so that I could post the answer with the hope that it will help someone else.

My Setup
- DB2 installed and reinstalled - but the 9505 error kept coming back
- I am the administrator on this machine. (Windows XP)
Solution -
- The problem specifically in my machine was that a temp directory was missing and creating that directory manually solved all the problems. DB2 was expecting a TMP directory under C:\Program Files\ibm\SQLLIB\DB2\ and there was none. So I created it.
How I found it (or What you can do to troubleshoot error on your machine) -
1) Make sure that all the DB2 Definitions are loaded
- Start -> Programs -> IBM DB2 -> Set-up Tools -> First Step
- Click on Configure Access to Remote Database option - which will open the Configuration Assistant
- Load your database definitions and close the Configuration Assistan.
2) From the First Step Window - Click on the second option on the left hand menu - "Work with Databases"
3) This will open Control Center
4) From the Control center window - Find the icon for the DB2 Command Editor (third or fourth icon from the left - that looks like a Window icon)
5) Click on it and try to connect to your database ( CONNECT TO DBNAME USER USERID USING PASSWORD )
6) You will see the error in the lower pane. The error I got was -
SQL1143N The operation cannot complete because a file error occured for the file "C:\PROGRA~1\IBM\SQLLIB\DB2\TMP\CCSCRIPT130129123947459".
Looks like DB2 is using this directory for storing session information of some kind and if it is not found, you get that error..