Kubernetes v1.15.1 is Now Available in IBM Cloud Kubernetes Service

1 min read

Easily upgrade your clusters to Kubernetes v1.15.1

We are excited to announce the availability of Kubernetes v1.15.1 for your clusters that are running in IBM Cloud Kubernetes Service. With the Kubernetes Service, you can easily upgrade your clusters without the need for deep Kubernetes knowledge. When you deploy new clusters, the default Kubernetes version remains 1.13; you can also choose to immediately deploy version 1.15. 

Learn more about deploying clusters here: “Tutorial: Creating Kubernetes clusters

Kubernetes v1.15

In addition to all the great Kubernetes features provided in this release, IBM Cloud Kubernetes Service version 1.15.1 also includes the following:

See the IBM Cloud Kubernetes Service version 1.15 changelog for details.

Kubernetes support and updates

IBM Cloud Kubernetes Service now supports the latest three versions of Kubernetes: 1.13, 1.14, and 1.15. Clusters that are running Kubernetes versions 1.11 and earlier are unsupported

Clusters running 1.12 are now deprecated with end-of-support tentatively scheduled for October 31.  It is important to note clusters that run deprecated or unsupported Kubernetes versions may not receive fixes for security vulnerabilities until they are updated to a supported version. 

Review the potential impact of each Kubernetes version update, and update your clusters today.

Join the conversation

For general questions, engage our team via Slack by registering here and join the discussion in the #general channel on our public IBM Cloud Kubernetes Service Slack.

Be the first to hear about news, product updates, and innovation from IBM Cloud