Troubleshooting
Problem
User runs standard report. User receives error message.
Symptom
QE-DEF-0288
Unable to find the data source 'IBMDADB2.DB2COPY1:servername:TCPport:DATABASECONNECTION:username' in the content store
Cause
There are many potential causes for this error.
- TIP: For more scenarios, see separate IBM Technote #1652954.
This IBM Technote specifically relates to the scenario where the cause is a known limitation (APAR PM80822) of Controller when using DB2 and manually specifying the TCP port.
Environment
Inside "Controller Configuration" the "Database Connection" contains the TCP port (e.g. 50000) inside the section "Location":
Resolving The Problem
Fix:
Upgrade to Controller 10.2 or later.
Workaround:
Manually rename the data source inside Cognos Connection.
Steps:
1. Launch Cognos Connection (http://servername/ibmcognos)
2. Navigate to "Administer IBM Cognos content" - "Configuration"
3. Click on "Data Source Connections"
4. Locate the relevant data source, and click "Properties" button:
5. Inside the "Name" section, rename the item slightly so that it includes the TCP port, for example:
- IBMDADB2.DB2COPY1:VBRACONTDB2:50000:RCTST04A:fastnet
TIP: For more information on creating Data Sources, see separate IBM Technote #1997625.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21616157