IBM Support

[Db2] Windows 7 以降 Db2 のセットアップが失敗する

Question & Answer


Question

管理者で Windows にログオンしているにもかかわらず、Db2 のセットアップが失敗します。原因と対処方法を教えてください。

Cause

Windows Vista 以降の Windows オペレーティング・システムではデフォルトでユーザーアクセス制御 (UAC) が有効になっています。
このため、Windows Vista, Windows 7, Windows Server 2008 などへ Db2 をインストールしようとすると、十分な権限がないためにインストールが失敗することがあります。

このとき setup.exe を実行したユーザーのドキュメントフォルダ (C:¥Users¥USER_NAME¥Documents¥) の下にある DB2LOG フォルダに、以下のような内容のログが記録されることがあります。
  • Property(C): VersionHandler = 5.00
    Property(C): CostingComplete = 0
    Property(C): SourcedirProduct = {B6773B66-7A0F-4C30-9661-5E5299E713B4}
    Property(C): DB2_INSTALL_LANG = JP
    Property(C): LAP_SUPPORTED_LANG = Y
    Property(C): SUMMARY_SUPPORTED = Y
    Property(C): CURRENT_PROCESS_DIRECTORY = C:\Users\USER1\LOCALS~1\Temp\_DB20000
    Property(C): TEMP_HELP_DIRECTORY = C:\Users\USER1\LOCALS~1\Temp\_DB20000
    Property(C): INSTALL_RESULT = Setup Completed with Error
    === ログ終了 : 2011/09/05  18:45:07 ===
    MSI (c) (2C:F4) [18:45:07:709]: 製品 : IBM Data Server Client -- インストールは失敗しました。

    MSI (c) (2C:F4) [18:45:07:709]: Windows インストーラーにより製品がインストールされました。製品名: IBM Data Server Client、製品バージョン: 9.7.400.501、製品の言語: 1041、製造元: IBM、インストールの成功またはエラーの状態: 1603

Answer

Db2 をセットアップするには管理者権限が必要です。
ビルトイン・アカウントの Administrator 以外の管理者でセットアップを実行する場合、setup.exe を [管理者として実行] で起動してください。

運用上の考慮点
セットアップ完了後も、Db2 の管理作業を行うには Windows の管理者権限が必要です。
コントロール・センターの使用や、コマンド行プロセッサーによる管理作業を行う場合も、[管理者として実行] で該当ツールを起動してください。拡張セキュリティーが有効になっている場合は、DB2ADMNS グループのメンバーになっていることも必要です。

拡張セキュリティー (DB2_EXTSECURITY) が有効かどうかは、DB2 コマンド・ウィンドウから以下のコマンドを実行して確認できます。
  • C:\>db2set -all | findstr EXTSEC
    [g] DB2_EXTSECURITY=YES

また、ローカル・コンピュータの DB2ADMNS グループのメンバー一覧は以下のコマンドで得られます。
  • C:\>net localgroup DB2ADMNS
    エイリアス名     DB2ADMNS
    コメント         このグループとローカル管理者は、オペレーティング・システムによってすべての DB2 オブジェクトに対する完全なアクセス権を持ちます。

    メンバー
    ------------------------------------
    db2admin
    コマンドは正常に終了しました。

関連情報
Windows 2008 および Windows Vista 以降に関する考慮事項: ユーザー・アクセス制御フィーチャー
[Db2] Db2 の Windows 7 対応クライアント (IM-10-00Z)
 
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008PknAAE","label":"Install\/Migrate\/Upgrade"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]

Document Information

Modified date:
04 November 2023

UID

swg21610147