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Installing WebSphere Operational Decision Management (WODM) V7.5

Question & Answer


Question

What are the steps to follow and the configuration aspects to take into account when installing WebSphere Operational Decision Management (WODM) V7.5?

Cause

The launchpad, introduced in V7.5, helps you install the prerequisites and the product components, in the correct order.

To understand the WODM components that the installer includes, read the section WebSphere Operational Decision Management V7.5 > Installing > Understanding your Operational Decision Management installation > Composition of Operational Decision Management of the WODM V7.5 information center.

First of all, refer to the product readme to ensure that your configuration complies with the hardware and software requirements.

Then, download the launchpad installer that corresponds to the environment where you are planning to run it. See the WODM V7.5 download document for all the available installers.

Space requirements

  • 7 GB (7,000 MB) of disk space to store the downloadable parts.
  • 7 GB (7,000 MB) of disk space to store the unpacked product files.
  • 11.2 GB (11,200 MB) of disk space to store the product and its files.

Note: The downloadable parts can be deleted after you unpack them.

To get the latest bug fixes, it is highly recommended that you also download the lasted fix pack for this version, and install it right after you have installed the base version. Each download page provides the steps to apply the corresponding fix pack.


A web browser is required to run the launchpad, either Firefox or Internet Explorer. See Browser requirements for the Launchpad for more details on the required versions for each supported platform.

If you are installing from a DVD, you must follow the instructions in technote Installing WebSphere Operational Decision Management V7.5 using DVDs.

To extract the installers using WinZip and avoid MD5 checksum errors, see the instructions of this Frequently asked question (FAQ) about WebSphere Decision Center.

If you are using AIX, there is a known limitation of the UNIX tar command which does not support long paths/file names. This may generate the following error while installing WODM: "A file or directory in the path name does not exist".
To prevent this issue, install GNU tar version 1.14 or higher. Then, verify that the system path variable contains both native UNIX tar and GNU tar paths and ensure that the GNU tar path (for example, /opt/freeware/bin/tar) is defined before the native UNIX tar path (/usr/bin).

Answer

To start the launchpad, use the executable (.exe or .sh) located under "disk 1" which is the root of the installer.

The launchpad.exe and launchpad64.exe files define the bit size that the launchpad itself runs in. The choice of one or the other does not determine whether you install a 32 or 64-bit WODM, but whether the launchpad will run in 32 or 64-bit.

In custom mode, you can select whether you want to install a 32-bit or a 64-bit WebSphere Application Server. In typical mode, the WebSphere Application Server installation is silent and chooses the version that matches the operating system.

However, the Eclipse installed (if selected), and its associated JDK (located under <WODMInstallDir>/jdk) are always in 32-bit.

On Linux, follow the instructions in this frequently asked question (FAQ) about WebSphere Decision Center to avoid permission issues.


The two options available when you start the WODM launchpad are:

  • Typical install
  • Custom install
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The typical install sets up all the prerequisites (WebSphere Application Server with IBM Business Space and WebSphere eXtreme Scale), all the modules for both Decision Server and Decision Center, and deploys all the Java EE components to the new WebSphere Application Server (WAS) instance. This last step is performed under a dedicated profile at the first start of the WAS sample server.

This option allows to have all modules on a default WAS configuration ready to run with no setup required.

If you want to install only certain modules, to deploy in your own existing WAS installation or use another application server provider, you will must use the custom installation option.

The custom install gives the option to choose to either install Decision Server, Decision Center or both, and select their components based on your needs.

The custom install first offers to install the prerequisites that you need to install, depending on what you already have and the WODM modules you will use:

  • WebSphere Application Server (WAS) is required for the event components or to deploy rule samples and tutorials.
  • IBM Business Space is required for the event runtime and widgets of Decision Server and for the Decision Center for business space component, as well as for the samples and tutorials.
  • WebSphere eXtreme Scale is required for the event runtime.

Note that if you want to use an existing WAS installation that was not installed with IBM Installation Manager, you must add it to the IBM Installation Manager repository. To do so, start IBM Installation Manager, and click Import.

Otherwise the message "The selection location does not contain WebSphere Application Server installation" will show when referencing the root of the existing WAS installation.

To perform the import, you might have to add the following URL in Preferences > Repositories of IBM Installation Manager: http://public.dhe.ibm.com/software/websphere/repositories/repository.config

See this frequently asked question (FAQ) about WebSphere Decision Center for more details.


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For more details on the steps to install WODM V7.5, see this Installing and setting up WebSphere Operational Decision Management document.

To perform a silent install of WODM V7.5, see technote Installing WebSphere Operational Decision Management 7.5 (WODM) in silent mode.


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Know issues

  • Choosing the "Typical Installation" option on Windows might cause the installer to hang for a long time. See technote The Typical Installation option is extremely slow on Windows to solve the issue
  • You might get the message "The version of IBM Business Space installed in the selected WebSphere Application Server instance is unsupported - must be 7.5 or later", although IBM Business Space V7.5.X is installed. See technote WODM 7.5 installer can not recognize business space to solve this issue.
  • Installing on Windows on a drive other than C:, and with Symantec Endpoint Protection enabled might trigger the following error: "...\WODM75\WAS\AppServer\java\docs\autorun.inf (Access is denied.)". To solve this issue and proceed with the installation, you can temporarily disable the tool or install on the C: drive.
  • If you are unable to install IBM Installation Manager on RHEL 6.0/6.1 64-bit, see technote Unable to install Installation Manager on RHEL 6.0/6.1 (64-bit).

For other known limitations on the installer, see Known limitations in WebSphere Operational Decision Management V7.5.

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Troubleshooting

If you face issues with the typical install, you can refer to the logs generated by the launchpad to know what the cause of the problem might be. These logs are located under:

  • /tmp/IBM_Launchpad_Typical_Install_XXXXXX on UNIX.
  • C:\Documents and Settings\<user>\Local Settings\Temp\IBM_LaunchPad_Typical_Install_XXXXXX on Windows.

In any case, you can also refer to the IBM Installation Manager logs.

[{"Product":{"code":"SSQP76","label":"IBM Operational Decision Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
10 August 2022

UID

swg21595346