IBM Support

WODM 7.5 installer can not recognize business space

Troubleshooting


Problem

Attempt to install WebSphere Operational Decision Management (WODM) on an existing WAS instance could fail because it can not recognise the Business Space when it was updated to 7.5.1

Symptom

When installing WODM from the launchpad using custom installation, the installer can not recognize the Business Space v7.5.1 installed in existing WebSphere Application Server (WAS) instance:

    The version of IBM Business Space installer in the selected WebSphere Application Server instance is unsupported - must be 7.5 or later.

Installation can not go beyond this point.

The same issue may occur with Business Space v8.0.0.

Cause

The installer can not recognize the Business Space v7.5.1 installed in existing WAS because the Business Space version is not specified in the expected V.R.M.F format.

Environment

WebSphere Application Server v7, business space v7.5.1

Resolving The Problem

Before installation, modify the business space version info in <AppServer>\BusinessSpace\bspace.versions.txt

change


    RTC.build.release=7.5.1

to

    RTC.build.release=7.5.1.0

After the installation, restore the version as originally.

Note: Business Space is no longer supported starting in V8.0.1 where Decision Server Events provides event widgets for testing event logic, capturing events, and replaying events. Decision Center supplies additional widgets for developing business logic and monitoring business event processing.

[{"Product":{"code":"SSQP76","label":"IBM Operational Decision Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.0;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
23 July 2021

UID

swg21580515