IBM Support

Smalltalk/V error: a non-continuable protection violation has occurred, when starting RequisitePro

Troubleshooting


Problem

When starting IBM® Rational® RequisitePro® on a Microsoft® Windows® Terminal Server 2003, RequisitePro crashes with a Smalltalk/V error: a non-continuable protection violation has occurred.

Cause

One cause of this error is that the user who installed RequisitePro on this system has not logged out and logged back in, to commit the installation changes to the Microsoft Windows registry.

Resolving The Problem

Official support for Windows Terminal Server 2003 is introduced in RequisitePro version 2003.06.15 and later. For additional information regarding Supported Platforms and Databases refer to the RequisitePro 2003.06: Documentation and supported platforms, environments and databases matrix

You can resolve this error by performing on of the following:

  • Have the current user log out and log back in so that the installation changes are committed to the Microsoft Windows registry completing the installation.
  • Local Server access: Reboot the server with a directly connected screen and keyboard/mouse. After logging on, you will see a message box informing you that Windows has actively terminated requisitepro.exe. From there, you can access the configuration dialog.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Open Project","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.15;2003.06.16","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21212259