Troubleshooting
Problem
This technote explains why creating local IBM® Rational® ClearCase® views fail after uninstalling McAfee® Firewall software on Microsoft® Windows®.
Symptom
The following errors are generated when trying to create a view:
H:\>cleartool mkview -tag view2 \\host1\views\view2.vws
cleartool: Error: Problem starting admin_server for host host1
cleartool: Error: See albd_log or admin_log on host host1
cleartool: Error: Cannot bind an admin_server handle on "host1":
error detected by ClearCase subsystem.
cleartool: Error: Unable to create view
"\\host1\views\view2.vws".
Cause
The McAfee Personal Firewall software is causing the problem; even though it has already been uninstalled via Add/Remove Programs in the Windows Control Panel.
The uninstall does not completely remove the networking components, which cause cleartool mkview to continue to fail with the above error. The firewall installs itself in the Winsock2 layer of the network on Windows.
- Click on Start > Run type winmsd and hit the Enter key.
Note: A window will pop up that says System Information.
- In the left hand pane of the window, expand the Components item.
- Then expand Network and click on Protocol.
- In the right hand pane of the window you will see an Item and a Value column.
Note: The first entry should be MSAFD Tcpip [TCP/IP] and the second should be MSAFD Tcpip [UDP/IP]. You will see McAfee_GdLsp at the top of the protocol stack.
For more assistance navigating the WINMSD graphical display, refer to the Microsoft Support Web Site.
Resolving The Problem
To remedy this issue, you will need to remove the McAfee Desktop Firewall application from the computer.
Note: Refer to the ClearCase Knowledge Center for more information on why ClearCase does not operate with firewall applications.
Related Information
Was this topic helpful?
Document Information
Modified date:
29 September 2018
UID
swg21154548