IBM Support

"You already have this version of Citrix Workspace installed, so the installer will exit" when trying to install the Citrix client, caused by a different user previously having installed the client

Troubleshooting


Problem

Controller on Cloud is powered by Citrix. Therefore all users require the Citrix client installed on their device (for example laptop).
User wants to install the Citrix Workspace client on their laptop/PC. They download the relevant file ("CitrixWorkspaceApp.exe") from the Citrix website. They double-click on the file. An error appears suggesting that it is already installed.
  • However, when they look at their PC (for example in Control Panel) they cannot see any evidence of it being installed.

Symptom

image 5461
You already have this version of Citrix Workspace installed, so the installer will exit
  
However, there is no 'Citrix Workspace' entry in either Control Panel "Apps"...
image 5462
...or the Start menu. In other words, there is not an entry similar to:
image 5463

Cause

The Citrix client has previously been installed inside a different Windows user's profile, so the client will only work when logged on as him/her.
Example:
In one real-life example:
  • Laptop belonged to someone who had a non-administrative Windows username: domain\standard_user
  • They logged onto their laptop as normal (as user "standard_user") and then double-clicked on the file "CitrixWorkspaceApp.exe"
  • Windows prompted them to type in an administrative username, so their I.T. department typed in an administrative Windows username:  domain\admin_user
After the installation wizard was completed the Citrix client did not work (when logged in as user "standard_user")

Diagnosing The Problem

The Citrix client does not get successfully installed to the correct/main location:  C:\Program Files (x86)\Citrix\ICA Client
  • Instead, it appears only in the 'admin' user's Windows user profile.
Specifically, it will appear in a folder similar to: C:\Users\admin_user\AppData\Local\Citrix

Resolving The Problem

Uninstall the Citrix workspace client using the Windows username: domain\admin_user
Install the Citrix workspace client using the Windows username: Administrator
Steps:
1. Logon to the client device as the user "standard\admin_user"
2. Create a shortcut to the file "CitrixWorkspaceApp.exe"
3. Modify the shortcut so that its argument is:   CitrixWorkspaceApp.exe -uninstall
image 5464
4. Hold down 'left Ctrl' and 'left Shift' (on your keyboard) and right-click on the shortcut icon
5. Choose "Run as different user"
image 5465
6. Authenticate as the same user who originally installed the software (for example "domain\admin_user")
7. Follow the wizard to uninstall the client:
image 5466
image 5467
8. Launch a Command Prompt as the user 'Administrator' (not domain\admin_user !)
image 5468
9. Inside the command prompt, use 'cd' to change directory to the folder where you have downloaded the installation file
  • For example:     cd C:\temp
10. Then type:    CitrixWorkspaceApp.exe
image 5471
11. Click 'Start' and follow the wizard to install the Citrix client:
image 5472
12. Test.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMRTZ","label":"IBM Cognos Controller on Cloud"},"ARM Category":[{"code":"a8m0z000000brHTAAY","label":"Citrix"}],"ARM Case Number":"TS004009010","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 October 2021

UID

ibm16257473