Troubleshooting
Problem
The CPU may grow to and stay at 100%
Symptom
Application will hang and require a restart to restore function.
Cause
When "WS Use GZip" in CCM Advanced Properties is turned on, the thread that uses this compression method does not terminate as expected. The large amount of these threads will cause CPU usage to grow and eventually causing server performance degradation.
Environment
All platforms
Diagnosing The Problem
Collect Java core while the issue is occurring.
If there are numerous threads reported in the javacore that have "at java/util/zip/Deflater.deflateBytes(Native Method)" as the top of the thread stack, then it is likely that "WS use GZip" is the problem.
An example of the thread:
at java/util/zip/Deflater.deflateBytes(Native Method)
at java/util/zip/Deflater.deflate(Deflater.java:455(Compiled Code))
at java/util/zip/Deflater.deflate(Deflater.java:377(Compiled Code))
at java/util/zip/DeflaterOutputStream.deflate(DeflaterOutputStream.java:262(Compiled Code))
at java/util/zip/DeflaterOutputStream.write(DeflaterOutputStream.java:222(Compiled Code)) ...
at java/util/zip/Deflater.deflateBytes(Native Method)
at java/util/zip/Deflater.deflate(Deflater.java:455(Compiled Code))
at java/util/zip/Deflater.deflate(Deflater.java:377(Compiled Code))
at java/util/zip/DeflaterOutputStream.deflate(DeflaterOutputStream.java:262(Compiled Code))
at java/util/zip/DeflaterOutputStream.write(DeflaterOutputStream.java:222(Compiled Code)) ...
Resolving The Problem
The temporary work around is to turn off (set to false) the "WS Use GZip" in the CCM server.
In order to update GZIP property to false, there are two ways to achieve. From the CCM Web client and teamserver.properties file of ccm. See both in details below:
1. When CCM web UI is accessible go to https://<SERVER>>:<PORT>/<context_of_ccm>/admin
2. Click on advanced property under configuration
3. Search for WS Use GZip
4. Change from true to false.
5. Save the setting.
2. Click on advanced property under configuration
3. Search for WS Use GZip
4. Change from true to false.
5. Save the setting.
Screen shot added to assist you from the web UI.
Alternatively update ccm's teamserver.proerties (this is useful when CCM process is down or planing to restart at some point later)
1. Go to /opt/IBM/<JazzTeamServer>/server/conf/ccm (or equivalent on your installation) and adjust path if you're on Windows
2. Back up existing teamserver.properties
3. At end of the file add com.ibm.team.repository.ws.use.gzip=false
4. Save the file.
2. Back up existing teamserver.properties
3. At end of the file add com.ibm.team.repository.ws.use.gzip=false
4. Save the file.
Note: The default value for this setting is true. A restart of the JVM containing CCM is required to clear the threads that are already affected by this issue. A permanent solution is currently under active investigation.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSUC3U","label":"IBM Engineering Workflow Management"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"6","Edition":"6.0.5, 6.0.6","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Product Synonym
Rational Team Concert
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Document Information
Modified date:
17 April 2019
UID
ibm10874616