Troubleshooting
Problem
Starting instance on Windows DB2 server gets error: SQL1042C An unexpected system error occurred or SQL1022C There is not enough memory available to process the command
Symptom
db2diag.log logs below messages: 2012-02-09-18.18.54.009000-300 E92834H421 LEVEL: Error (OS) PID : 3248 TID : 3256 PROC : db2syscs.exe INSTANCE: DB2 NODE : 000 EDUID : 3256 FUNCTION: DB2 UDB, oper system services, sqloGetAccountSID, probe:30 MESSAGE : ZRC=0x83000534=-2097150668 CALLED : OS, -, LookupAccountName OSERR : 1332 "No mapping between account names and security IDs was done." 2012-02-09-18.18.54.009000-300 I93257H297 LEVEL: Severe PID : 3248 TID : 3256 PROC : db2syscs.exe INSTANCE: DB2 NODE : 000 EDUID : 3256 FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:450 MESSAGE : ZRC=0x83000534=-2097150668
Another type of symptom is SQL1022C returned from db2start
2019-01-01-12.29.00.052000-240 I35844860F467 LEVEL: Event PID : 1234 TID : 2792 PROC : db2syscs.exe INSTANCE: DB2INST1 NODE : 000 HOSTNAME: ibmtest EDUID : 2792 FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:5659 MESSAGE : ZRC=0xFFFFFC02=-1022 SQL1022C There is not enough memory available to process the command.
Cause
Windows failed to find the SIDs on the workstation. This may be due to incorrect workstation or domain name specified for DB2USERS and/or DB2ADMNS group (if extended security is enabled).
Environment
Windows
Diagnosing The Problem
In regedit, check the below registry keys:
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\GLOBAL_PROFILE\DB2_ADMINGROUP
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\GLOBAL_PROFILE\DB2_USERSGROUP
The above two registry keys should have values set in this format:
For local groups: <workstation>\<groupname>
For domain groups: <domain>\<groupname>
Check if incorrect workstation or domain name are set for DB2USERS group or DB2ADMNS group.
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\GLOBAL_PROFILE\DB2_ADMINGROUP
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\GLOBAL_PROFILE\DB2_USERSGROUP
The above two registry keys should have values set in this format:
For local groups: <workstation>\<groupname>
For domain groups: <domain>\<groupname>
Check if incorrect workstation or domain name are set for DB2USERS group or DB2ADMNS group.
Resolving The Problem
Use db2extsec command to correct the DB2USERS and DB2ADMNS group names.
For local groups:
db2extsec /u <workstation>\<db2users> /a <workstation>\<db2admns>
For domain groups:
db2extsec /u <domain>\<db2users> /a <domain>\<db2admns>
Related Information
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Component":"Security \/ Plug-Ins - IBM Suplied\/Default","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.8;9.7;9.5;9.1;11.1;10.5;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
24 April 2019
UID
swg21584354