Troubleshooting
Problem
Windows® 10 PCs fail to map a NetServer network drive when NetServer is using SMB2. The following error is received:
Network Error
Windows® cannot access \\NetServer_Name
Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnosis
Error code 0x80004005
Unspecified Error
Windows® cannot access \\NetServer_Name
Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnosis
Error code 0x80004005
Unspecified Error
Symptom
TRCCNN, collected on the IBM i, shows the following sequence:
R - SYN
S - SYN ACK
R - NEGOTIATE
S - SMB2_NEGOTIATE
R - SMB2_SESSION_SETUP
S - SMB2_SESSION_SETUP 'accept_incomplete'
R - SMB2_SESSION_SETUP
S - SMB2_SESSION SETUP SMB2_SESSION_FLAG_IS_GUEST
R - RST ACK
Cause
This error is caused by the client PC attempting to make a guest connection to the server when the client is configured to require SMB signing. There is no secret key available to decrypt the client session key for guest connections, so the server cannot sign the session setup response. Windows® appears to have security enhancements in place on the client that are preventing the unsecured connection to the server.
Microsoft® support document 'Guest access in SMB2 disabled by default in Windows' describes the issue. At the time of this writing, the document is found here:
https://support.microsoft.com/en-us/help/4046019
Resolving The Problem
Follow recommendations provided by Microsoft®.
Document Location
Worldwide
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Document Information
Modified date:
18 December 2019
UID
ibm11116399