Troubleshooting
Problem
Attempting to upgrade Atlas results in the following error message: *** ERROR: Cannot retrieve latest installed schema version
Cause
Database client/server issues, or configuration issues.
Diagnosing The Problem
Check the smf_properties.ini file to ensure the database connection information entered here is correct, and can be used to connect to the database outside of Atlas.
Resolving The Problem
The most common cause for this issue is incorrect details in the smf_properties.ini file. Make sure the connection information entered here. See this documentation for how to correctly configure this file.
If the information configured is correct and works outside of Atlas, there may be an issue with the database client. Common problems could be:
- Mismatched database client vs database server versions
- 32 bit client vs 64 bit server (or vice versa)
- Network connectivity issues.
Even if the database connection is successful, these issues may only arise when the upgrade script is ran.
The best way around these problems is to perform the upgrade directly on the database, instead of on a remote client machine.
Was this topic helpful?
Document Information
More support for:
Atlas eDiscovery Process Management
Software version:
6.0
Operating system(s):
Linux, Solaris, Windows
Document number:
278509
Modified date:
17 June 2018
UID
swg21982782