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While Outlook is running in cached exchange mode, a MAPI_E_NOT_FOUND error occurs during an interactive archiving process

Question & Answer


Question

When you try to archive email from a PST file or another folder while Microsoft® Outlook is running in cached exchange mode, the archiving process fails with a MAPI_E_NOT_FOUND error.

Cause

The CommonStore for Exchange Server (CSX) Task reads job requests for which the corresponding messages are not yet available. In cached exchange mode, the folders of an Outlook client are synchronized with the folders on the Exchange server after a certain time interval has elapsed. This means that the messages to be archived do not reach the Exchange server before the next synchronization event.

However, submitting an interactive archiving request immediately creates a job request in the public job folder on the Exchange server. The CSX Task reads the job messages and tries to process the corresponding email messages. These might be unavailable because the synchronization interval has not passed and the messages have not yet been copied to the Exchange server. This is the situation in which the MAPI_E_NOT_FOUND error occurs.

Answer

Turn the cached exchange mode off before starting interactive archiving jobs.

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Document Information

Modified date:
17 June 2018

UID

swg21238886