IBM Support

While loading order details page, We are seeing "API Security Violation Error".

Troubleshooting


Problem

While loading order details page, user is observing "API Security Violation Error".

Symptom

If order-details route is customized (You can confirm by checking if "order-details": {"type": "code" } is present in package-customization.json ) and icc.order.summary.getReturnOrdersCount and icc.order.summary.getReturnOrders mashups are not overridden, then on upgrading to 25.3.9.1 with your old extensions you might see this error:

Cause

In October 2025 there are several mashups related to Order Details being updated to fix specific issues. These mashups have larger impacts on the existing code. So if in the exiting customization, mashups are NOT updated, then the users will encounter the "API Security Violation Error"

The "Upgrade Impact" section has been included in the October Release. Refer to the link: https://www.ibm.com/docs/en/call-center/10.0.0?topic=generation-whats-new

Diagnosing The Problem

 

Resolving The Problem

The resolution is to update all the mashups from the new code-base in the existing customization setup and redeploy it in the application through SST.

You can apply a quick workaround by updating your oms extensions jar with the 2 mashups: icc.order.summary.getReturnOrdersCount and icc.order.summary.getReturnOrders . Follow the steps outlined:

1.       Create the icc_order_incrementalmashups.xml file with the following code:

<?xml version="1.0" encoding="UTF-8"?>
<mashups>
<mashup description="Gets the number of return orders associated with an order" id="icc.order.summary.getReturnOrdersCount" mashuptype="XAPI" transactional="true" skipDataProvider="true">
<classInformation name="com.ibm.icc.common.mashups.ICCBaseMashup" />
<API Name="getOrderList">
<Input>
<Order >
<OrderLine>
<DerivedFrom DocumentType="" OrderHeaderKey=""/>
</OrderLine>
</Order>
</Input>
</API>
</mashup>
<mashup description="Gets the returns order associated with an order" id="icc.order.summary.getReturnOrders" mashuptype="XAPI" transactional="true" skipDataProvider="true">
<classInformation name="com.ibm.icc.common.mashups.ICCBasePaginatedMashup" />
<API Name="getOrderList">
<Input>
<Order>
<OrderLine>
<DerivedFrom DocumentType="" OrderHeaderKey=""/>
</OrderLine>
</Order>
</Input>
</API>
</mashup>
</mashups>

2.       Check your oms extensions jar to see if you extended  icc.order.summary.getReturnOrdersCount or icc.order.summary.getReturnOrders mashup ids through incremental mashup extensions.

a.       If yes, then refer to the shared file and add <DerivedFrom DocumentType="" OrderHeaderKey=""/> to your extended mashup definitions.

b.       If no, copy icc_order_incrementalmashups.xml file to your oms extensions jar in the following path - extensions/files/extensions/icc/webpages/mashupxmls/order/

3.       Re-deploy your oms extensions jar through SST

Document Location

Worldwide

[{"Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSYLSL","label":"IBM Sterling Call Center"},"ARM Category":[{"code":"a8m0z000000cxzVAAQ","label":"Call Center Store and SIM"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;9.3.0;9.4.0;9.5.0;SaaS","Type":"MASTER"}]

Product Synonym

call-center; icc; call center; sterling call center;

Document Information

Modified date:
08 November 2025

UID

ibm17250578