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While creating a Purchase Order, error encounters - ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" Attribute Name="BaseTransactionKey" Value="INCLUDE_IN_DERIVED_ORDER"

Troubleshooting


Problem

While creating a Purchase Order, the confirmShipment API fails with an error:
<Errors> <Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" ErrorRelatedMoreInfo=""> <Attribute Name="ErrorCode" Value="YCP0063"/> <Attribute Name="ErrorDescription" Value="Invalid Transaction"/>

Symptom

After a Deployment, the Confirm Shipment for a Purchase Order consistently fails with an error:

<Errors> <Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" ErrorRelatedMoreInfo=""> <Attribute Name="ErrorCode" Value="YCP0063"/> <Attribute Name="ErrorDescription" Value="Invalid Transaction"/> <Error ErrorCode="com.yantra.yfs.japi.YFSException" ErrorDescription="" ErrorRelatedMoreInfo="<?xml version="1.0" encoding="UTF-8"?> <Errors> <Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction" ErrorRelatedMoreInfo=""> <Attribute Name="ErrorCode" Value="YCP0063"/> <Attribute Name="ErrorDescription" Value="Invalid Transaction"/> <Attribute Name="BaseTransactionKey" Value="INCLUDE_IN_DERIVED_ORDER"/> <Attribute Name="ProcessTypeKey" Value="PO_FULFILLMENT"/> <Stack>com.yantra.yfc.util.YFCException at com.yantra.omp.business.order.returns.OMPReturnOrderUtils.getReturnOrderDocType(OMPReturnOrderUtils.java:289) at com.yantra.omp.customdbhelper.YFSOrderLineGetXMLHelper.massageStandardGetXML(YFSOrderLineGetXMLHelper.java:628)

Cause

The YFS_TRANSACTION table is missing the required entry for a record with the following details:

  • BaseTransactionKey: INCLUDE_IN_DERIVED_ORDER
  • ProcessTypeKey: PO_FULFILLMENT

This missing entry is causing the confirmShipment process to fail with the "Invalid Transaction" error.

Alternatively, the issue could stem from a discrepancy between the templates used for PurchaseOrder—with the working environment using a different template than the non-working one.

Diagnosing The Problem

Verify if the BaseTransactionKey INCLUDE_IN_DERIVED_ORDER exists for a Purchase Order in YFS_TRANSACTION table by running the following SQL query:

SELECT BASE_TRANSACTION_KEY, *
FROM OMDB.YFS_TRANSACTION
WHERE BASE_TRANSACTION_KEY = 'INCLUDE_IN_DERIVED_ORDER'
ORDER BY PROCESS_TYPE_KEY;

Resolving The Problem

  • Identify the Working Environment:
    Determine which environment (e.g., Master Configuration or PreProduction) is processing Purchase Orders successfully.

  • Verify the Transaction Record:
    Run the following SQL query in the working environment to confirm the presence of the required transaction record:

    SELECT BASE_TRANSACTION_KEY, * FROM OMDB.YFS_TRANSACTION WHERE BASE_TRANSACTION_KEY = 'INCLUDE_IN_DERIVED_ORDER' ORDER BY PROCESS_TYPE_KEY;
  • Template Comparison:
    In the working environment, check if different templates are used for createOrder and/or confirmShipment. Compare these templates with those in the non-working environment and apply any necessary adjustments.

  • Addressing YFS_TRANSACTION Discrepancies:
    If no template differences are found, but the YFS_TRANSACTION table shows discrepancies between the working and non-working environments, perform the following steps:

    • Export the CDT (Configuration Data Tool) from the working environment, including the YFS_TRANSACTION table.
    • Import the CDT into the lower environments (e.g., QA) for validation.
  • Validation and Replication:
    Ensure that the confirmShipment process runs smoothly after the import. Once validated, replicate the fix in Production, following standard best practices.

Document Location

Worldwide


[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy00AAA","label":"Orders"}],"ARM Case Number":"TS017664230","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Product Synonym

oms
sterling

Document Information

More support for:
IBM Sterling Order Management

Component:
Orders

Software version:
All Versions

Document number:
7174192

Modified date:
26 October 2024

UID

ibm17174192

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