IBM Support

When using IBM Stewardship Center, an error appears while trying to access dashboards.

Troubleshooting


Problem

IBM Stewardship Center 11.6.0.4 is supported on IBM BPM 8.5.7 CF 2017.06. With this BPM upgrade dashboards are creating problems and throwing error such as “this.getNode(...) is undefined. Then a server (401) error appears, stating that access is denied to a REST URL due to insufficient credentials”

Cause

This occurred because of some core internal BPM changes with version 8.5.7 CF 2017.06.

Environment

IBM Stewardship Center 11.6.0.4 with IBM Business Process Manager 8.5.7 CF 2017.06

Resolving The Problem

Follow the steps given to avoid the errors mentioned.

1. In a web browser, navigate to to IBM BPM WebSphere Admin console

2. From the left hand side navigation tree, click into Resources > Resource Environment > Resource Environment Providers

3. Click "Mashups_ConfigService" link in table

4. Click "Custom properties" in the Additional Properties section

5. Click the "New" button

6. Type "com.ibm.bpm.portal.disableCFJSAPIInvocation" for the Name (do
not type the quotes)

7. Type "true" for the value (do not type the quotes)

8. Click Apply and then Save the configuration

9. Restart the server.

Note : You should also clear the browser cache.

Devworks article link for same issue :

https://developer.ibm.com/answers/questions/403713/getting-an-error-when%20-using-mdmisc-with-bpm-857-cf.html?childToView=403714#answer-403714

[{"Product":{"code":"SSWSR9","label":"IBM InfoSphere Master Data Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF010","label":"HP-UX"}],"Version":"11.6.0.4","Edition":"Advanced Edition","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 April 2022

UID

swg22010896