IBM Support

When trying to login to Business Space from a browser you are not getting a login prompt and the page is blank

Troubleshooting


Problem

The Business Space applications have been successfully deployed with IBM Case Manager (ICM) Administration Client (CMAC). You try to test and validate if the Business Space is configured properly before proceeding with the rest of the ICM configuration tasks by hitting the Business Space [ http://servername:port.mum/enabler], instead of getting a prompt to login to Business application, you are getting a blank page

Symptom


The Business Space data source is trying to connect to the default database schema named MASHUPS instead of the real Schema defined for the Business Space database in CMAC.

For DB2 database, you will see the errors below in WAS ICM SystemOut.log file:


    --- The error occurred in com/ibm/mm/server/persistence/rdbms/resources/maps/FileStore.xml.
    --- The error occurred while applying a parameter map.
    --- Check the readPathByID-InlineParameterMap.
    --- Check the statement (query failed).
    --- Cause: com.ibm.db2.jcc.am.SqlSyntaxErrorException: DB2 SQL Error: SQLCODE=-204, SQLSTATE=42704, SQLERRMC=MASHUPS.FILESTORE_PATH, DRIVER=3.61.65
    com.ibatis.common.jdbc.exception.NestedSQLException:
    --- The error occurred in com/ibm/mm/server/persistence/rdbms/resources/maps/FileStore.xml.
    --- The error occurred while applying a parameter map.
    --- Check the readPathByID-InlineParameterMap.
    --- Check the statement (query failed).
    --- Cause: com.ibm.db2.jcc.am.SqlSyntaxErrorException: DB2 SQL Error: SQLCODE=-204, SQLSTATE=42704, SQLERRMC=MASHUPS.FILESTORE_PATH, DRIVER=3.61.65
    at com.ibatis.sqlmap.engine.mapping.statement.GeneralStatement.executeQueryWithCallback(GeneralStatement.java:185)
    ...
    ...

For Oracle database, you will see a similar error reported in WAS ICM SystemOut.log as follows :
    com.ibm.mm.server.persistence.rdbms.dao.ibatis.BaseDao getRoot BMWSD0429E: An SQLException was encountered while communicating with the database. Error code: 942, SQL State: 42000, Message:
    --- The error occurred in com/ibm/mm/server/persistence/rdbms/resources/maps/FileStore.xml.
    --- The error occurred while applying a parameter map.
    --- Check the readPathByID-InlineParameterMap.
    --- Check the statement (query failed).
    --- Cause: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist
    ...
    ...

Cause

The wrong schema name was configured for the Business Space application.

Environment

This is an ICM 5.1 in a highly available environment.

Diagnosing The Problem

Collect Business Space Logs using steps below

  1. Restart WebSphere Application (WAS)
  2. Log on to WAS administrative console.
  3. In the left panel, expand Troubleshooting and click on Logs and Trace
  4. Select the application server to be traced, and than on the next page click the Diagnostic Trace link.
  5. Select the Runtime tab
  6. Under Trace Output, verify the output file location. Important note: Do not select Save Runtime Changes to Configuration as well if you do not want this setting to become permanent.
  7. On same panel click on Change Log Detail Levels under Additional Properties on right side panel.
  8. Select the Runtime tab.
  9. Under Trace Specification, enter trace string below. Notice we are enabling additional security logging) *=info: com.ibm.bspace.*=all: com.ibm.mm.*=all:com.ibm.ws.security.*=all
  10. Reproduce the problem. For example, verify whether a user can not login or can not create a space.

Resolving The Problem

  1. On the Deployment Manager node, re-run the Configure Business Space Database CMAC task. See the related ICM 5.1 Infocenter link based on your deployment profile.
    a. For development profile:
    Configuring the development environment for cluster or network deployment

    b. For production profile:
    Configuring the production environment for cluster or network deployment
  2. Validate the ConfigServices.properties file to make sure that the schema information is updated as expected. In a clustered environment, this file is located on the deployment manager, in <deployment_manager_profile_root>/BusinessSpace/<Business_Space_cluster_name>/mm.runtime.prof/config. Open the file in a text editor and search for schemaName and verify that the value is set correctly, for example:
    schemaName=BSPACE.
    Please note that the dot at the end of the schemaName is required.
  3. Validate by logging into WAS console that the custom property schemeName has the matching value. Navigate to Resource Environment -> Resource Environment Providers -> Mashups_ConfigService -> Custom properties -> schemaName

If the problem is not resolved after you have carried out the above steps, please contact the IBM Response Center at 1-800-IBM-SERV.

[{"Product":{"code":"SSCTJ4","label":"IBM Case Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Case Manager Client","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"5.1.0.1;5.1.1.0;5.1.0.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21598047