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What is the syntax for a dsdump, cleanup and dsload? How does it work?

Troubleshooting


Problem

What is the syntax for a dsdump, cleanup and dsload? How do they work? When would I need to use them?

Cause

When files are deleted (for example, output PDF files and deleted imr files), the iwr7x.db file does not decrease in size and is not expected to. In order to decrease the iwr7x.db file, it would have to be rebuilt in order to remove older non-existent references to files. Rebuilding this file during cleanup is not possible as the iwr7x.db file is always being accessed. This is why the Cognos IWR Service Manager (CerX) service must always be stopped when deleting the iwr7x.db file.

The only alternative to "decrease" the iwr7x.db file is to use the dump and load process. In an xml file produced by the dsdump process there is a <CogIWRRMPurgeList></CogIWRRMPurgeList>. The entries in this list are output files, or report files that no longer exist. The entries associated with this purge list and other information pertaining to deleted information will not be carried over during the load process. Therefore, the new iwr7x.db file after the load is performed, will be much smaller than the original iwr7x.db file that was used to create the dump xml file.

As an example, in one test, a dsload using an iwroutput.xml file produced the resulting iwr7x.db file which was 32 megabytes. Next, a standard cleanup process was performed. One of the rules of cleanup is that if a file does not exist, it will be deleted. Since we did not have any output files, the cleanup process removed approximately 2000 entries from the iwr datastore. The dsdump produced an xml file that was much smaller than the iwroutput.xml file. After the dsload was performed, the new iwr7x.db file would be significantly smaller

Environment

Windows 2003, all varieties of UNIX

Resolving The Problem

The steps are straightforward. If a test/scratch server is available, it's receommeneded to run through this until you are comfortable with the process.

The task should take about 1/2 hour, depending on the number of servers (services) to be shut down - restart etc... with the majority of the time attributed to stopping and starting of services.

Note: As always, ensure all files are backed up prior to attempting this and ensure you are comfortable with the restore process should you encounter any problems. Steps to back up and restore your environment can be found in the Backup and Recovery Guide which ships with the product.

Steps:1. Perform a dsdump through command prompt at the ?/Cognos/cer#/bin level:

The syntax for dsdump is:

dsdump -db <dbPath> -v all -l <log file name> -fn <output file name> -frc

where

  • The <dbPath> is the path to the directory where your iwr7#*.db files are located, i.e.("...\Cognos\Cer#\Databases\ directory") NOTE: Use quotation marks around all paths.
  • The value -v can be 1,2,3 or all and is used to specify the trace level output into the log.
  • <log file name> is an outputted log file name including path.
  • The <output file name> is the file (including its path) that you will use later for the dsload.
  • The -frc is for the force option. Use this if you are experiencing errors on dumping the reports.

2. Create new *.db files:

i. Shut down your Cognos services through Configuration Manager (verify that your IWR services and two Object Store services are stopped).
ii. Remove the four *.db files found in \Cognos\Cer#\Databases\ directory.
Note: You should keep these 4 iwr7#*.db files in a safe and separate backup location.
iii. Restart your Cognos services and verify that new *.db files have been created.

3. Perform a dsload through command prompt:

i. The dsload should be performed from the actual IWR server (not remotely).
ii. Upfront and Object Store services should be running while the IWR Service should be stopped.

The syntax for the dsload is:

dsload -db <dbPath> -fn <input file name> -v all -un <admin logonID> -pw <pwd>

4. Restart all services.

Attached is a Word Document that shows the commands via screenshots.

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Historical Number

1035499

Document Information

Modified date:
15 June 2018

UID

swg21371190