IBM Support

WebSphere Portal V6.1.0.2 hardware and software requirements - Microsoft Windows

Product Documentation


Abstract

IBM WebSphere Portal V6.1.0.2 hardware and software requirements on a Microsoft Windows operating system. The hardware and software requirements reflect the versions of prerequisites and corequisites that were tested with WebSphere Portal V6.1.0.2.

Content

WebSphere Portal V6.1.0.2 hardware and software requirements


WebSphere Portal Server Version 6.1.0.2 (Microsoft Windows)
This page describes the minimum product levels that must be installed before opening a problem report with IBM WebSphere Portal Technical Support. The software versions and any maintenance levels listed on this page have been explicitly verified as working.

EARLIER LEVEL OF A LISTED SOFTWARE: Software versions at a lower level than those noted on this page are unsupported. LDAP software at an earlier level is considered untested and best effort support only. For more details and exceptions, refer to the WebSphere Portal 6.1.x Support Statement. Also see the listing of software explicitly not supported for use with WebSphere Portal 6.1.x in WebSphere Portal Support Statement Addendum - Unsupported Products (#7012957).

LATER LEVEL OF A LISTED SOFTWARE: Because other products frequently ship fixes, updates, and new releases, testing every configuration is not possible. In general, you can install and run with updates to supported products if those updates are compatible with the tested versions. For more details and exceptions, refer to the WebSphere Portal 6.1.x Support Statement. Also see the listing of software explicitly not supported for use with WebSphere Portal 6.1.x in WebSphere Portal Support Statement Addendum - Unsupported Products (#7012957).

UNLISTED SOFTWARE: Software not listed on this page at any level is unsupported. LDAP software not listed is considered untested and best effort support only. For more details and exceptions, refer to the WebSphere Portal 6.1.x Support Statement. Also see the listing of software explicitly not supported for use with WebSphere Portal 6.1.x in WebSphere Portal Support Statement Addendum - Unsupported Products (#7012957).



Operating systems
supported with 32-bit WebSphere Application Server and WebSphere Portal


Operating systems
supported with 64-bit WebSphere Application Server and WebSphere Portal


Microsoft Windows hardware requirements
  • Minimum 2.5 GB free disk space for installation for WebSphere Portal
  • Minimum 1.0 GB free disk space for installation for WebSphere Application Server
  • Minimum 4GB total disk space recommended for installation
  • x86-32: Intel Pentium processor at 500MHz or faster, AMD Opteron (32 bit kernel support only), Intel EM64T (32 bit kernel support only)
  • x86-64: AMD Opteron (64 bit kernel support only), Intel EM64T (64 bit kernel support only)
  • Physical memory: Under minimal load, WebSphere Portal can function with 2GB of RAM. However, 4GB is an optimal starting point for RAM in a production environment.
  • CD-ROM drive


JavaTM
The WebSphere-supplied Java 2 SDK is required for both the run time and any remote Java clients.
  • IBM 32-bit SDK for Windows, Java 2 Technology Edition, V5.0 SR8
  • IBM 64-bit SDK for Windows on AMD64/EM64T architecture, Java 2 Technology Edition, V5.0 SR8
  • IBM SDK for Microsoft Windows, Java Technology Edition, Version 6.0 with Application Server version 7.0


Application Servers
  • WebSphere Application Server base or Network Deployment (ND) V7.0.0.1 with JDK 1.6 SR3, WebSphere Application Server base or Network Deployment (ND) V6.1.0.21 with JDK1.5 SR8, with optional Extended Deployment V6.1.0.4, with optional WebSphere Process Server V6.2 or V6.1.2 or V6.1.0.1 (WebSphere Application Server product site)(See Required detail2a)


Databases


Java Database Connectivity (JDBC) Drivers
  • Derby embedded JDBC driver
  • DB2 Driver for JDBC and SQLJ 3.1 (type 2/4)
  • DB2 Universal JDBC Driver from DB2 for z/OS (type 2/4)
  • Oracle 9i or 10g or 11g JDBC Driver Thin (type 4) (Oracle JDBC product site) (See Required detail4e)
  • Microsoft SQL Server 2005 JDBC Driver v1.2


Web servers


Web browsers
(required for administration/configuration, sample program execution and launch pad. There is no restriction nor certification of Web browsers on clients that connect the server to display content)


LDAP servers






Software for content management (optional)


Supported Java Runtime Environments - Web Content Manager authoring portlet


External Security software (optional)


Software for portlet development
  • IBM Rational Application Developer Version 7.5 & 7.0.0.6 (plugin for UTE)
  • IBM WebSphere Portlet Factory 6.1


Other supported software (optional)
  • WebSphere Commerce Server


Software for license management
  • IBM Tivoli License Compliance Manager Version 2.3

Related information


Detailed system requirements
WebSphere Portal Information Centers and more
Support Statement

Top of page

See disclaimer.



Required details:
1. Supported for development only.

2a. Refer to Required WebSphere Interim fixes for WebSphere Portal Version 6.1.0.2 for the complete list of fixes required for WebSphere Application Server.

3. Supports High Availability Disaster Recovery (HADR) Feature.

4a. Oracle Database clustering using RAC on all supported Oracle levels. Supports connect time failover.

4b. Oracle Edition 11g requires Oracle patch 6362104 which patches the JDBC driver archive. If WebSphere Portal and Oracle are installed on two separate machines, copy the JDBC driver archive (ojdbc5.jar) from the Oracle server to the WebSphere Portal server after applying patch 6362104. If Websphere Portal and Oracle are installed on the same physical machine, ensure that the WebSphere Application Server JDBC provider for Oracle points to the patched JDBC driver archive.

4c. Supports Automatic Storage Management (ASM) Feature.

4d. The Oracle 10g Release 2 (10.2.0.2) JDBC driver is required when using Oracle to store Web Content Manager data.

4e. The Oracle 11g driver ojdbc6.jar is required for all Portal environments installed with WebSphere Application Server 7.0.0.x.

5a. Apache Server 2.0.5.9 includes CERT Advisory CA-2002-17. Apache 2.2.x is supported with WebSphere Application Server 7.0.

5b. HTTP Server 7.0 is supported with WebSphere Application Server 7.0 only.

5c. HTTP Server for i5/OS is provided natively on System i5 and is not bundled with or installed by WebSphere Portal. For V5R4, supported group PTF is SF99114 level 13; for V6R1, supported group PTF is SF99115 level 1. For V5R4, the license program number is 5722DG1; for V6R1, the license program number is 5761DG1. Issue the GO LICPGM to display all the installed licensed programs. For WebSphere Application 6.1.0.21 on V6R1M0, apply SI35071. For WebSphere Application 7.0.0.1 on V6R1M0, apply SI35078.

5d. To use Lotus Domino Version 7.0 with WebSphere Application Server 6.1, you must install the Web Server plug-in for Lotus Domino Server Version 6 which is a part of the Web Server plug-in for WebSphere Application Server 6.1. [

6a. Safari is not supported for use with the Common Mail portlet. For additional information, see Limitations on Safari Web browser.

6b. Opera is not supported for use with the Common Mail portlet or the Domino and Extended Products Portlets. For additional information, see Limitations on Opera Web browser.

7a. For 7.0.2 and 7.0.1: Apply SPR KLIN6LRTHJ to be able to return Groups and Users by direct lookup. Turkish users should use version 7.0.3 or later.

7b. Add APAR IO02714 available at IBM Support.

8. For information, see WebSphere Portal product family wiki.

9. When using Tivoli Access Manager 6.0 for authorization or integrated user provisioning with WebSphere Portal, the Tivoli Access Manager AMJRTE component must be at the Version 5.1 fix pack 2 level or later. This version of AMJRTE component is automatically installed with WebSphere Application Server Version 5.1.1 or later, but must still be configured to work with WebSphere Portal .
Top of page

Disclaimer


IBM reserves the right to change specifications and other product information without prior notice. This publication could include technical inaccuracies or typographical errors. References herein to IBM products and services do not imply that IBM intends to make them available in other countries. IBM PROVIDES THIS PUBLICATION AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

Top of page

[{"Product":{"code":"SS8KYD","label":"WebSphere Portal End of Support Products"},"Business Unit":{"code":"BU012","label":"WCE"},"Component":"Installation & Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.1.0.2","Edition":"Enable;Extend;Server"}]

Document Information

Modified date:
27 August 2018

UID

swg27014996