IBM Support

WebSphere Application Server Network Deployment - Edge Components

Product Documentation


Abstract

The table provides the system requirement for IBM WebSphere Application Server v9.0 Network Deployment - Edge Components per component.


Content

For V9R0, system requirements for the Edge Components are exclusively maintained in the following tables.

For V8R5, see the following document: https://www.ibm.com/support/pages/node/593703


Before engaging IBM® support for assistance, review the minimum product levels for IBM® WebSphere Application Server Edge components. Because other products frequently ship fixes, updates, and new releases, it is not possible to test every configuration. In general, you can install and run with updates to supported products if those updates are compatible with later version. Refer to support article WebSphere Application Server has grown and so have your requirements for support for configurations that are not included in the following list.

Unsupported Configurations
  • Edge Caching Proxy is not supported on Red Hat Enterprise Linux 8.0 (and later) due to the removal of compat-libstdc++-33
  • Edge Load Balancer is not supported on Windows Server 2016 and higher
Supported Configurations

Edge Components: Caching Proxy

AIX®

OS Minimum Hardware Bitness
AIX 7.1 POWER System - Big Endian 64-Exploit; 64-Tolerate
AIX 7.2 POWER System - Big Endian 64-Exploit; 64-Tolerate

Linux®

OS Minimum
Hardware Bitness Notes
Red Hat Enterprise Linux (RHEL) Server 7 IBM Z systems 64-Exploit
POWER System - Big Endian 64-Exploit; 64-Tolerant
POWER System - Little Endian 64-Exploit; 64-Tolerant
x86-64 64-Exploit; 64-Tolerant
SUSE Linux Enterprise Server (SLES) 12.0 IBM Z systems 64-Exploit
POWER System - Big Endian 64-Exploit; 64-Tolerant
POWER System - Little Endian 64-Exploit
x86-64 64-Exploit; 64-Tolerant
SUSE Linux Enterprise Server (SLES) 15.0 x86-64 64-Exploit; 64-Tolerant
Ubuntu 16.04 LTS x86-64 64-Exploit; 64-Tolerant Requires "rpm" package
POWER System - Big Endian 64-Exploit; 64-Tolerant Requires "rpm" package
POWER System - Little Endian 64-Exploit Requires "rpm" package
Ubuntu 18.04 LTS x86-64 64-Exploit; 64-Tolerant Requires "rpm" package
POWER System - Big Endian 64-Exploit; 64-Tolerant Requires "rpm" package
POWER System - Little Endian 64-Exploit Requires "rpm" package
  

Windows®

OS Minimum Hardware Bitness
Windows Server 2012 Datacenter x86-64 64-Exploit; 64-Tolerate
Windows Server 2012 Essentials x86-64 64-Exploit; 64-Tolerate
Windows Server 2012 R2 Datacenter x86-64 64-Exploit; 64-Tolerate
Windows Server 2012 R2 Essentials x86-64 64-Exploit; 64-Tolerate
Windows Server 2016 Standard x86-64 64-Exploit; 64-Tolerate
Windows Server 2016 Datacenter x86-64 64-Exploit; 64-Tolerate
Windows Server 2016 Essentials x86-64 64-Exploit; 64-Tolerate

Note: The Content Based Routing component (with Caching Proxy) runs as a 32-bit application on the 64-bit platforms listed as supported.

Edge Components: Load Balancer for IPV6 and IPV4

AIX®

OS Minimum Hardware Bitness
AIX 7.1 POWER System - Big Endian 64-Exploit
AIX 7.2 POWER System - Big Endian 64-Exploit
AIX 7.3 SP01 BD2148 POWER System - Big Endian 64-Exploit
 


Linux®

OS Minimum Hardware Bitness
Red Hat Enterprise Linux (RHEL) Server 7 IBM Z systems 64-Exploit
POWER System - Big Endian 64-Exploit
POWER System - Little Endian 64-Exploit
x86-64 64-Exploit
Red Hat Enterprise Linux (RHEL) Server 8 x86-64 64-Exploit
SUSE Linux Enterprise Server (SLES) 12.0 IBM Z systems 64-Exploit
x86-64 64-Exploit
SUSE Linux Enterprise Server (SLES) 15.0 POWER System - Little Endian 64-Exploit
x86-64 64-Exploit
Ubuntu 14.04 LTS POWER System - Little Endian 64-Exploit
x86_64 64-Exploit
Ubuntu 16.04 LTS POWER System - Little Endian 64-Exploit
x86_64 64-Exploit
Ubuntu 18.04 LTS POWER System - Little Endian 64-Exploit
x86_64 64-Exploit
Ubuntu 20.04 LTS POWER System - Little Endian 64-Exploit
x86_64 64-Exploit

Windows®

OS Minimum Hardware Bitness
Windows Server 2012 Datacenter x86-64 64-Exploit [2]
Windows Server 2012 Essentials x86-64 64-Exploit [2]
Windows Server 2012 Standard x86-64 64-Exploit [2]
 

Note:
[1] Dispatcher component is not supported on these operating systems.
[2] Dispatcher component is stabilized at this level of the operating system and future levels are not supported.

Virtualization Support for Load Balancer

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Edge Component","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0.0.0","Edition":"Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
14 April 2022

UID

swg27048441