Troubleshooting
Problem
When the Webform Server is not responding, it is possible that the Access Control Server (Database) and the Shared File Cache are no longer synchronized with each other. This technote discusses determining if the Access Control Server and the Shared File Cache are out of sync with each other and the steps to correct the problem.
Cause
If you see java.lang.NullPointerException in the error.xml file and the Translator is not responding, this indicates that the Access Control Server and the Shared File Cache are out of synchronization with each other.
Environment
All operating system platforms and all versions of Webform Server.
Diagnosing The Problem
Access the toolbelt located at http://<hostname>:8085/translator/Translate?pwsAction=toolbelt . If the Webform Server translator is not responding and you see the error below in the error.xml file located at <Webform Server Install Directory>\LogServer\logs\translator folder, then you have this problem.
Error text:
<logEvent level="SEVERE" time="2008-02-29 11:00:09,766">
<error>
<context>web2/10.99.234.204</context>
<message>java.lang.NullPointerException</message>
<errorHistory>java.lang.NullPointerException
at
com.ibm.form.webform.translator.fom.FOMUtils.prependPageName(FOMUtils.j
va:275)
at
com.ibm.form.webform.translator.GlobalFormTemplateStoreImpl$ImageCreati
gListener.handleNode(GlobalFormTemplateStoreImpl.java:537)
at
com.ibm.form.webform.translator.TreeWalker.notifyListeners(TreeWalker.j
va:258)
at com.ibm.form.webform.translator.TreeWalker.walk(TreeWalker.java:295
at
com.ibm.form.webform.translator.GlobalFormTemplateStoreImpl.extractEncl
sures(GlobalFormTemplateStoreImpl.java:168)
at
com.ibm.form.webform.resourcestore.FormTemplateProvider_DOMImpl$Install
emplateCommand.execute(FormTemplateProvider_DOMImpl.java:534)
at
com.ibm.form.webform.resourcestore.FormTemplateProvider_DOMImpl$CacheUp
ateThread.run(FormTemplateProvider_DOMImpl.java:662)
</errorHistory>
Resolving The Problem
Follow the steps below to correct the problem by restoring the synchronization between the Access Control Server and the Shared File Cache:
1. Stop the Webform Server service
2. Navigate to the <Webform Server Install Dir>\SharedFileCache folder
3. Delete all the files within the SharedFileCache folder
4. Clear entries depending on your database type:
*Note: WS_ACDB is the default database name, if you changed it then please remember to substitute it in all the places where WS_ACDB is referenced. The table prefix, WS_, can also be customized in the translator.properties by changing <entry key="tablePrefix">WS_</entry>.
Webform Server 3.0.x
Using DB2: Open WS_ACDB and drop the AC_table and AC_Control table
- Using Cloudscape: Navigate to the <WebSphere install dir>\AppServer\cloudscape\WS_ACDB, and delete the entire WS_ACDB folder
**Note: DB2 and Oracle tables use the same names. More details on dropping tables can be found in the information center for DB2 and Oracle.
Webform Server 3.5.x
DB2 and Oracle
- Open WS_ACDB and drop the WS_<tableName> tables.
- WS_ACCESSCONTROL
- WS_FORM_METADATA
- WS_FORMNODEP_METADATA
- WS_INFO
- Open WS_ACDB and drop the WS_<tableName> tables.
- WS_ACCESSCONTROL
- WS_ACCESSCONTROL_STATE
- WS_FORMNODEP_METADATA
- WS_FORM_METADATA
- WS_INFO
5. Start the Webform Server service
6. Open a browser and access the toolbelt at the following address:
WebForm Server 3.0.x
http://<hostname>:8085/translator/Translate?pwsAction=toolbelt
WebForm Server 3.5.x and 4.0.x
http://<hostname>:8085/translator/Translate?Action=toolbelt
The Translator is now able to respond, and you can open the toolbelt without error.
Related Information
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Document Information
Modified date:
15 November 2019
UID
swg21296903