IBM Support

Web Query - migrate/save/restore

Question & Answer


Question

How does one handle a migration of WebQuery from one IBM i to another IBM i?
Perhaps you bought a new IBM i?
Or you upgraded hardware?
Does a complete system save and complete system restore work for WebQuery?
Can I save WebQuery
Can I verify that WebQuery is saved as part of my company's back up plan?
After a migration to new hardware (and I cannot get back to the original hardware) how do I handle this error:
image-20190510090916-1

Cause

Doing a complete system save and complete system restore does work for all IBM i products.   This is true for WebQuery unless two different IBM i boxes are involved.
Library QWQREPOS and /QIBM/UserData/qwebqry/apps should be part of your back up process.

If you happen to have an issue with WebQuery migration,
you want to do a manual migration,
or you want to 'save WebQuery',
here are some notes to assist and some notes on any existing testing (etc) you may have done on the target (or new) IBM i before the migration.
The result of a MIGWEBQRY is a savefile that can be used as a 'save of WebQuery'.

Answer

Please note: All development/test work in WebQuery on the target IBM i will be lost during this process, with an exception for IBM supplied folders (for example IBM DB2 Web Query Information, IBM i Administrations Samples)

The migration from one IBM i to another IBM i does not merge the various reports, etc., on the target box with the data from the source IBM i, it will over write them.

If there are any WebQuery top level folders, metadata, reports that should be preserved on the target IBM i during the migration, you must export them using Change Management and save them so that you can import them when the migration is complete.



If you want to do a manual migration from one IBM i to another IBM i, please refer to the Migrate Web Query (MIGWEBQRY) Command User Manual.
If you no longer have access to the original IBM i you can try these steps to associate the correct Authorization List to the matching Top Level Folder
a. On the new hardware
wrklnk '/qibm/userdata/qwebqry/base80/logs'
b. Do a 5=Display on the appropriate event.log  (there is one for each day)
c. search for
ERROR_WQLM_AUTHLIST_UPDATE_FAILED
d.  the preceding line in that event.log will tell you the Top Level Folder that is having the issue.
It'll look something like this:
addToAuthList requestingUser:ktrisko for profileType:X profileName:KTGRP authType:READ appName:/qibm/userdata/qwebqry/apps/ktrisko_toplevelfolder
In this example, the Top Level Folder is ktrisko_toplevelfolder
e. Go to the WebQuery Authorization Lists
WRKAUTL AUTL(QWQ0*)
f.  One of these authorization lists will be for the Top Level Folder with the issue.
It's not likely to be QWQ0000000, QWQ0000001, or QWQ0000002 - these are *usually* for Top Level Folders Common, IBM Db2 Web Query Information, Retail Samples
Do an 8=Display objects in list on each QWQ* authorization list.
If there is at least one folder under the Top Level Folder, you'll see it on this list.
A F22=Display entire name on the 'name' will show you the entire name and that can be used to determine if this is the authorization list that should be associated with Top Level Folder
g. Once you've found the correct authorization list, 'attach' it to the Top Level Folder via CHGAUT.   Here's an example:
CHGAUT OBJ('/qibm/userdata/qwebqry/apps/ktrisko_toplevelfolder') AUTL(QWQ0000003)

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m500000008jKuAAI","label":"IBM i WebQuery-\u003EInstall Uninstall Upgrade Migration"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]

Historical Number

N1020479

Document Information

Modified date:
06 June 2023

UID

nas8N1020479