IBM Support

Watson Studio Local - Error loading notebook when trying to open or edit a Jupyter notebook

Troubleshooting


Problem

You are getting an error when trying to open a specific Jupyter notebook. Other notebooks open up just fine.
When looking in the corresponding Jupyter pod log you see messages like "Notebook does not appear to be JSON".

Cause

Corrupted JSON format (cause unknown).

Resolving The Problem

Jupyter Notebook files (.ipynb) are stored in JSON format. When using a JSON validity checker (several free checkers can be found on the internet) you might find errors like the below:

Error: parse error on line xx: Expecting 'EOF', got ','.

You could check if the number of open/closed {} and [] char's is the same (you could also find character count tools for free on the internet).

If the number of open and closed chars are not the same, you can manually fix the JSON code and check if the notebook opens again.


Document Location

Worldwide


[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSHGWL","label":"IBM Watson Studio Local"},"ARM Category":[{"code":"a8m0z000000bnp2AAA","label":"Modeling->Notebook - Jupyter"}],"ARM Case Number":"TS004877992","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

More support for:
IBM Watson Studio Local

Component:
Modeling->Notebook - Jupyter

Software version:
All Version(s)

Document number:
6408944

Modified date:
27 January 2021

UID

ibm16408944