Question & Answer
Question
How can I determine the cause of errors seen in syslog for PowerVM Virtual I/O Server (VIOS), and how can I stop them?
This applies to VIOS 3.1
Cause
/etc/syslog.conf is primarily to be used by SupportLine personnel for P/D purposes.
Any errors of concern need to be assessed on a case by case basis by IBM Supportline to ascertain if the errors relate to functionality currently being used by the VIOS partition where the errors are being logged. For example, if you see messages related to cluster, but the VIOS is not part of a VIOS Cluster configuration (also known as Shared Storage Spools), then the messages can be safely ignored. See Related URL.
Any errors of concern need to be assessed on a case by case basis by IBM Supportline to ascertain if the errors relate to functionality currently being used by the VIOS partition where the errors are being logged. For example, if you see messages related to cluster, but the VIOS is not part of a VIOS Cluster configuration (also known as Shared Storage Spools), then the messages can be safely ignored. See Related URL.
Answer
Unlike AIX OS, the VIOS is an appliance. Commands are only provided in
Here are the lines added to a VIOS syslog.conf file, by default, during VIOS installation. These lines are not commented, by default:
padmin shell for system administration activities. padmin command line interface is the only supported method for managing the VIOS.
oem_setup_env is only available for installing and configuring supported third-party storage and multipathing software, as documented in oem_setup_env command. Anything other than that needed for VIOS administration is provided in the padmin shell. If you have a need for functionality that is not currently available in padmin shell for the currently supported VIOS release, feedback can be submitted to VIOS development by submitting IBM ideas.
Here are the lines added to a VIOS syslog.conf file, by default, during VIOS installation. These lines are not commented, by default:
user.info /var/adm/lpm/lpm.log rotate size 10m files 2 compress
user.debug /var/adm/lpm/lpm.dbg rotate size 20m files 8 compress
caa.debug /var/adm/ras/syslog.caa rotate size 10m files 10 compress
user.debug /var/adm/lpm/lpm.dbg rotate size 20m files 8 compress
caa.debug /var/adm/ras/syslog.caa rotate size 10m files 10 compress
/etc/syslog.conf file cannot be modified as padmin user. Any other uncommented entries in this file are not supported, unless they were added at the request of IBM Supportline for specific problem determination. It is not recommended to alter this file (or any other VIOS configuration) via oem_setup_env.Related Information
[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m50000000L0LLAA0","label":"PowerVM VIOS-\u003EERROR LOG"}],"ARM Case Number":"TS011861480","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
28 May 2025
UID
isg3T1023508