Troubleshooting
Problem
Why is VIOS boot process delayed after "ASO" message.
Symptom
VIOS boot up process stops for a while after the following message is displayed. The boot process eventually comes up to the login prompt.
[STOP] Virtual I/O server detected, ASO will exit.
Cause
Network, NFS, or DNS problem.
Environment
VIOS 2.2
Diagnosing The Problem
If VIOS is known to be having network issues, those issues need to be resolved first.
Resolving The Problem
If VIOS network connectivity works fine, check for NFS or DNS problem.
If the VIOS is an NFS client:
1. Verify NFS entry in /etc/initab. As padmin
- $ oem_setup_env
# lsitab -a|more >it should look something like this:
...
aso:23456789:once:/usr/bin/startsrc -s aso
rcnfs:23456789:wait:/etc/rc.nfs > /dev/console 2>&1 # Start NFS Daemons
...
# exit (back to padmin)
2. Check console log for signs of problems around the date/time ASO process was started and the boot delay was experienced. As padmin:
- $ oem_setup_env
# alog -o -f /var/adm/ras/conslog > console.log
# vi console.log (to exit vi mode, hit ESC key, type :q! <Enter>
# exit (back to padmin)
3. Rename /etc/resolv.conf to /etc/resolv.conf.old and test the reboot again. If reboot comes up fast, check the name server in /etc/resolv.conf and make sure DNS entries are correct.
4. Check for loopback entries in /etc/hosts. If there's only one line there for the local IP, you need to add loopback entries in /etc/hosts because many services need to lookup localhost/loopback.
For networking questions, contact your local IBM Network Support Representative.
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Document Information
Modified date:
19 February 2022
UID
isg3T1026009