IBM Support

View Client volatile environment variables not visible

Troubleshooting


Problem

Volatile Environment Variables do not show on the guest operating system when you run the SET command from a command prompt. This information is available in the registry, but is not accessible from the Environment variables.

Symptom

  • Volatile Environment Variables do not show on the guest operating system when you run the SET command from a command prompt.
  • This information is available in the registry, but is not accessible from the Environment variables.

Cause

If the explorer process takes a long time to load, it fails to read the information provided by wssm and the Environment Variables on the Command prompt are not set.

Environment

View 4.0, 4.5, 4.6, 5.0

Diagnosing The Problem

The symptom is visible in a cmd.exe session within the Guest OS by running the "set" command.

Resolving The Problem

VMware® KB 2004779 provides a workaround to the issue. The issue is also resolved in the View 4.6.1 and 5.0.1 update.

This bullet entry in the View 5.0.1 Release Notes is referring to the same issue as KB 2004779.

    • Miscellaneous

          Previously, if you opened a command prompt in a View desktop and ran the set command, the list of environment variables displayed would sometimes not include the volatile environment variables for View Client. This issue has been resolved.

[{"Product":{"code":"SSCLB3","label":"VMware Solutions"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"View","Platform":[{"code":"","label":"VMWare"}],"Version":"5.0","Edition":"","Line of Business":{"code":"LOB66","label":"Technology Lifecycle Services"}}]

Document Information

More support for:
VMware Solutions

Software version:
5.0

Operating system(s):
VMWare

Document number:
671007

Modified date:
27 February 2020

UID

isg3T1013055

Manage My Notification Subscriptions