IBM Support

Very slow logon to Cognos Connection caused by firewall not opening relevant ports

Troubleshooting


Problem

User launches Cognos Connection (URL: //servername/cognos8). User tries to logon (e.g. using Windows Active Directy username/passowrd). There is a very long pause (Cognos BI appears to hang). After a long time (e.g. 20 to 30 minutes) eventually the user is authenticated.

Symptom

Very slow logon (e.g. 20 to 30 minutes).

Cause

Networking delays caused by customer's firewall not dynamically opening ports correctly.

For example, in one real-life customer example, the firewall was correctly opening the ports for other services (e.g. Telnet) but not for Cognos.

Environment

Firewall between gateway server and client device.

Resolving The Problem

Reconfigure firewall (located between gateway and client).

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21591686