Troubleshooting
Problem
User opens a spreadsheet report (XLSX file). User logs into Controller (Excel link), and presses F9 to run (refresh) the report.
This takes a very long time.
Symptom
The symptoms may vary slightly:
- Sometimes the initial 'Analyzing sheet' phase may be faster than when re-running the same report immediately afterwards
- However, always the 'Fetching Values' phase takes a very long time.
During the 'Fetching Values' stage, the EXCEL.EXE was running at around 90-100%
- In other words, all CPU cores (for example all 4 in a quad-core client device) were more or less running entirely the excel.exe calculations.
Cause
There are many known causes for slow Excel link reports.
- TIP: See separate IBM Technote #1347497 for more examples.
This Technote specifically relates to the scenario where the cause is a defect (reference APAR PH04948), with respect to the speed of the function fStatus (cc.fStatus).
Diagnosing The Problem
Count the total number of fStatus formulae in your report.
1. Inside Excel, click CTRL-F
2. Change 'Find what' to be: fStatus
3. Click 'Options'
4. Change 'Within' to be 'Workbook'
5. Click 'Find All':
Resolving The Problem
Fix
Upgrade to Controller 10.4 (or later).
Workaround:
Reduce the total number of fStatus formulae in your report.
Related Information
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Document Information
Modified date:
18 January 2019
UID
ibm10738809