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Very poor performance when running reports after migration or server upgrade

Troubleshooting


Problem

Customer has a new Controller environment. For example, they may have: (a) recently migrated from an older version to a newer version of Controllerx. or (b) have recently migrated/upgraded Controller system to new server hardware. Afterwards, all users experience very poor performance in almost all areas of the application.

Symptom

All users affected inside all functions. As an example, when running reports (menu item "Reports - Run") it is very slow.

Cause

There are several potential root causes for slow performance.

  • For more examples, separate IBM Technote articles.

This IBM Technote deals specifically with the scenario where the cause is slow network speed between the 'application' and 'database' servers.

Example:
For example, one customer experienced speed increase of report from 150 seconds to 20 seconds after fixing their network connection.

Resolving The Problem

Ask I.T. department's network administrator to check that the server's network card (NIC) and network hub/switch settings are correct. Ensure that both the Controller 'application' server and database (e.g. SQL) server are checked.

Steps:

For instructions on how to test network speed, see separate IBM Technote #1347841.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.4;8.3","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1039507

Document Information

Modified date:
15 June 2018

UID

swg21382321