IBM Support

Version compatibility for Rational DOORS Web Access, interoperation server, Rational DOORS database server and client

Question & Answer


Question

What are the version compatibility requirements for Rational DOORS Web Access, the interoperation server, the Rational DOORS database server, and the Rational DOORS client?

Answer

The following tables present the version compatibility requirements for Rational DOORS Web Access, the interoperation server, the Rational DOORS database server, and the Rational DOORS client. Other fix pack releases that are not listed in this document address specific security issues. For version compatibility for those fix packs, refer to the previous release in the following tables. See also the download documents, fix lists, and security bulletins for those releases.


Rational DOORS Web Access in a non-OSLC environment

DOORS Web Access
Interoperation Server
Database Server
Client
1.1.0.0 (November 2008)
9.1.0.0
9.x
9.x
1.1.0.1 (March 2009)
9.1.0.1
9.x
9.x
1.2.0.0 (May 2009)
9.2.0.0
>= 9.2.0.0
9.x
1.3.0.0 (November 2009)
9.2.0.2
>= 9.2.0.0
9.x
1.3.0.1 (March 2010)
9.2.0.3
>= 9.2.0.0
9.x
1.3.0.2 (June 2010)
9.2.0.4
>= 9.2.0.0
9.x
1.4.0.0 (September 2010)
9.3.0.0
>= 9.2.0.0
9.x
1.4.0.1 (December 2010)
9.3.0.1
>= 9.2.0.0
9.x
1.4.0.2 (March 2011)
9.3.0.3
>= 9.2.0.0
9.x
1.4.0.3 (March 2011)
9.3.0.3
>= 9.2.0.0
9.x
1.4.0.4 (June 2011)
9.3.0.4
>= 9.2.0.0
9.x
1.4.0.5 (September 2011)
9.3.0.5
>= 9.2.0.0
9.x
1.5.0.0 (June 2012)
9.4.0.0
>= 9.2.0.0
9.x
1.5.0.1 (September 2012)
9.4.0.1
>= 9.2.0.0
9.x
9.5.0.0 (November 2012)
9.5.0.0
>= 9.2.0.0
9.x
9.5.0.1 (March 2013)
9.5.0.1
>= 9.2.0.0
9.x
9.5.1.0 (June 2013)
9.5.1.0
>= 9.2.0.0
9.x
9.5.1.1 (June 2013)
9.5.1.1
>= 9.2.0.0
9.x
9.5.1.2 (September 2013)
9.5.1.2
>= 9.2.0.0
9.x
9.5.2.0 (December 2013)
9.5.2.0
>= 9.2.0.0
9.x
9.5.2.1 (February 2014)
9.5.2.1
>= 9.2.0.0
9.x
9.5.2.2 (May 2014)
9.5.2.2
>= 9.2.0.0
9.x
9.6.0 (May 2014)
9.6.0 (32-bit)
>= 9.2.0.0
9.x
9.6.0.1 (September 2014)
9.6.0.1 (32 bit)
>= 9.2.0.0
9.x
9.6.1.0 (December 2014)
9.6.1.0
>= 9.2.0.0
9.x
9.6.1.1 (March 2015)
9.6.1.1
>= 9.2.0.0
9.x
9.6.1.3 (June 2015)
9.6.1.3
>= 9.2.0.0
9.x
9.6.1.4 (October 2015)
9.6.1.4 - 9.6.1.6 *
>=9.2.0.0
9.x
9.6.1.7 (December 2016)
9.6.1.7
>=9.2.0.0
9.x
9.6.1.8 (April 2017)
9.6.1.8
>=9.2.0.0
9.x
9.6.1.9 (June 2017)
9.6.1.9
>=9.2.0.0
9.x
9.6.1.10 (December 2017)
9.6.1.10
>=9.2.0.0
9.x

* Rational DOORS 9.6.1.5 and 9.6.1.6 did not include DOORS Web Access components, but if you are using the DOORS client from those releases as an interoperation server, you must add the following property in the festival.xml file: <f:property name="interop.version" value="9.6.1.6"/>
For more information, see the Knowledge Center for help on modifying the core configuration file.



The 64-bit Rational DOORS client is not supported as a Rational DOORS Web Access interoperation server in versions 9.6.0 and 9.6.0.1. Please use the 32-bit client with those versions.

Version 9.2.0.0 of the Rational DOORS database server introduced object-level locking, which is a prerequisite for the editing functionality in Rational DOORS Web Access.

Rational DOORS Web Access does not place any restrictions on the version of Rational DOORS client that can connect to the database server. The standard minor client rule continues to apply, that is, any version 9.x desktop client can connect to any version 9.x server.

Rational DOORS Web Access in an OSLC environment

DOORS Web Access
OSLC
Interoperation Server
Database Server
Client
1.4.0.0 (September 2010)
V1
9.3.0.0
>= 9.2.0.0
9.3.0.0
1.4.0.1 (December 2010)
V1
9.3.0.1
>= 9.2.0.0
9.3.0.1
1.4.0.2 (March 2011)
V1
9.3.0.3
>= 9.2.0.0
9.3.0.3
1.4.0.3 (March 2011)
V1
9.3.0.3
>= 9.2.0.0
9.3.0.3
1.4.0.4 (June 2011)
V1
9.3.0.4
>= 9.2.0.0
9.3.0.4
1.4.0.5 (September 2011)
V1
9.3.0.5
>= 9.2.0.0
9.3.0.5
1.5.0.0 (June 2012)
V1, V2
9.4.0.0
>= 9.4.0.0
9.4.0.0
1.5.0.1 (September 2012)
V1, V2
9.4.0.1
>= 9.4.0.1
9.4.0.1
9.5.0.0 (November 2012)
V1, V2
9.5.0.0
>= 9.4.0.1
9.5.0.0
9.5.0.1 (March 2013)
V1, V2
9.5.0.1
>= 9.4.0.1
9.5.0.1
9.5.1.0 (June 2013)
V1, V2
9.5.1.0
>= 9.4.0.1
9.5.1.0
9.5.1.1 (June 2013)
V1, V2
9.5.1.1
>= 9.4.0.1
9.5.1.1
9.5.1.2 (September 2013)
V1, V2
9.5.1.2
>= 9.4.0.1
9.5.1.2
9.5.2.0 (December 2013)
V1, V2
9.5.2.0
>= 9.4.0.1
9.5.2.0
9.5.2.1 (February 2014)
V1, V2
9.5.2.1
>=9.4.0.1
9.5.2.1
9.5.2.2 (May 2014)
V1, V2
9.5.2.2
>=9.4.0.1
9.5.2.2
9.6.0 (May 2014)
V1, V2
9.6.0 (32-bit)
>=9.4.0.1
9.6.0
9.6.0.1 (September 2014)
V1, V2
9.6.0.1 (32 bit)
>= 9.4.0.1
9.6.0.1
9.6.1.0 (December 2014)
V1, V2
9.6.1.0
>= 9.4.0.1
9.6.1.0
9.6.1.1 (March 2015)
V1, V2
9.6.1.1
>= 9.4.0.1
9.6.1.1
9.6.1.3 (June 2015)
V1, V2
9.6.1.3
>=9.4.0.1
9.6.1.3
9.6.1.4 (October 2015)
V1, V2
9.6.1.4 - 9.6.1.6 *
>=9.4.0.1
9.6.1.4 - 9.6.1.6
9.6.1.7 (December 2016)
V1, V2
9.6.1.7
>=9.4.0.1
9.6.1.7
9.6.1.8 (April 2017)
V1, V2
9.6.1.8
>=9.4.0.1
9.6.1.8
9.6.1.9 (June 2017)
V1, V2
9.6.1.9
>=9.4.0.1
9.6.1.9
9.6.1.10 (December 2017)
V1, V2
9.6.1.10
>=9.4.0.1
9.6.1.10

* Rational DOORS 9.6.1.5 and 9.6.1.6 did not include DOORS Web Access components, but if you are using the DOORS client from those releases as an interoperation server, you must add the following property in the festival.xml file: <f:property name="interop.version" value="9.6.1.6"/>
For more information, see the Knowledge Center for help on modifying the core configuration file.

The 64-bit Rational DOORS client is not supported as a Rational DOORS Web Access interoperation server in versions 9.6.0 and 9.6.0.1. Please use the 32-bit client with those versions.

Rational DOORS Web Access is responsible for providing OSLC Requirements Management (RM) services to consuming applications, such as Rational Team Concert and Rational Quality Manager. Therefore, if you upgrade Rational DOORS to integrate with other Rational products using OSLC, then it is best practice to upgrade Rational DOORS Web Access to the corresponding Rational DOORS version.

[{"Product":{"code":"SSYQBZ","label":"Rational DOORS"},"Business Unit":{"code":"BU005","label":"IoT"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"1.1;1.2;1.3;1.3.0.1;1.3.0.2;1.4;1.4.0.1;1.4.0.2;1.4.0.3;1.4.0.4;1.4.0.5;1.5;1.5.0.1;9.0;9.1;9.1.0.2;9.2;9.2.0.1;9.2.0.2;9.2.0.3;9.2.0.4;9.2.0.5;9.3;9.3.0.1;9.3.0.10;9.3.0.11;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.3.0.8;9.3.0.9;9.4;9.4.0.1;9.4.0.2;9.4.0.3;9.4.0.4;9.4.0.5;9.5;9.5.0.1;9.5.0.2;9.5.0.3;9.5.0.4;9.5.0.5;9.5.1;9.5.1.1;9.5.1.2;9.5.1.3;9.5.1.4;9.5.1.5;9.5.1.6;9.5.2;9.5.2.1;9.5.2.2;9.5.2.3;9.5.2.4;9.5.2.5;9.6;9.6.0.1;9.6.0.2;9.6.0.3;9.6.0.4;9.6.1;9.6.1.1;9.6.1.10;9.6.1.2;9.6.1.3;9.6.1.4;9.6.1.7;9.6.1.8;9.6.1.9","Edition":""},{"Product":{"code":"SSYQCV","label":"Rational DOORS Web Access"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"1.1;1.2;1.3;1.3.0.1;1.3.0.2;1.4;1.4.0.1;1.4.0.2;1.4.0.3;1.4.0.4;1.4.0.5;1.5;1.5.0.1;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.2;9.5.2.1;9.6;9.6.0.1;9.6.1;9.6.1.1;9.6.1.3;9.6.1.4;9.6.1.7","Edition":""}]

Document Information

Modified date:
16 June 2018

UID

swg21661512