Troubleshooting
Problem
Vault plugins can sometimes fail with the following error reported in the operational logs:
rpc error: code = Unavailable desc = connection error: desc = "transport: error while dialing: dial unix /tmp/plugin111100000: connect: no such file or directory"
Cause
When Vault starts with containerized plugins, a socket file is created in the /tmp (default) directory to facilitate Unix socket communication. If these files become unavailable, the plugin will stop working and results in the above error in Vault operational logs.
The most common cause for the file to become unavailable is due to it being removed by the Systemd tmpfs cleanup.
Resolving The Problem
A restart of the Vault service will result in Vault recreating the temporary file, which will resolve the file not found error.
If the issue continues and the file continues to disappear, another option is to modify the timing of the Systemd-tmpfs cleanup, increasing the time between cleanups can help avoid the periods where Vault does not access the socket file.
Finally, if modifying the temporary file cleanup schedule is not possible or to avoid it having any potential impact, use of the Vault configuration parameter plugin_tmpdir can be used to specify a new directory that Vault will use to create the socket files in. You will need to ensure that whichever directory is chosen, Vault has sufficient access to create and modify files.
Document Location
Worldwide
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Document Information
Modified date:
13 May 2026
UID
ibm17270067