Question & Answer
Question
How do I use the Microsoft complete memory dump process to troubleshoot FileNet P8 and Image Services (IS) issues?
Cause
When troubleshooting instances where it is difficult to identify the offending process(es), assistance from Microsoft support might be required. When other tools do not provide sufficient insight, Microsoft may request that a complete memory dump be taken at the time of failure.
Answer
The server must first be configured to allow complete memory dumps, and the following steps should be explicitly followed if such a dump is requested by Microsoft:
1. If the server has a restart feature enabled, such as Compaq's Automatic System Restart (ASR), please disable it. This setting is usually found in the BIOS. With this type of feature enabled, if the BIOS does not detect a heartbeat from the OS, it will restart the server, and therefore interrupt the dump process.
2. Configure the required memory dump Registry settings for:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters\CrashOnCtrlScroll - set to 1 (DWORD)
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\GlobalFlag - set to 400 (hex)
NOTE: If these values were non-zero before the change, be sure to save the key. Once troubleshooting is complete, restore the original settings.
3. Set the Virtual Memory size for the dump:
- Right-Click My Computer and select Properties.
- Go to the Advanced Tab and click Performance Options.
- Click Change under Virtual Memory.
- Set the pagefile on the partition where the OS is install to be equal to 4094 MB for BOTH the Maximum and Minimum
- Once this is done DO NOT enter this GUI utility again as it will UNSET the next item.
4. Set the dump parameters in the Registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
“AutoReboot" set to 00000001 (DWORD)
"CrashDumpEnabled" set to 00000001 (DWORD)
"LogEvent" set to 00000001 (DWORD)
"Overwrite" set to 00000001 (DWORD)
"SendAlert" set to 00000001 (DWORD)
5. Modify the boot.ini by adding /PAE /MAXMEM=3800 after /FASTDETECT
6. Reboot the server.
7. Generate a “memory.dmp” file by holding down the right CTRL key and pressing the SCROLL LOCK key twice. NOTE: Make sure that you use the CTRL key on the right side of the SPACEBAR.
Data to collect: The memory dump, which will be output to WINNT(%SystemRoot%)\memory.dmp. Include a description of any known circumstances leading up to the issue and document the time at which the issue occurred. Also provide the Application and System Event Logs.
For more information: See the Microsoft website
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Document Information
Modified date:
14 July 2021
UID
swg21394546