Troubleshooting
Problem
If TEP client (desktop, browser or Java Web Start) is running with Sun Java (both v1.5 or v1.6) instead of the IBM JVM, some of the ITCAM for WAS or ITCAM for AD workspaces will not show as expected.
Symptom
Impacted workspaces are the Application Servers Summary, the Topology View and possibly others. Here is an example:
Cause
The Sun JVM does not include certain third-party software components, like Xerces and Xalan. Some ITM agents rely on these APIs. For example, the Xalan API is needed by ITCAM for SOA (see link below for a specific Technote).
Resolving The Problem
The workaround is to copy the Xerces JARs into the Sun Java jre\lib\ext directory. The JARs will be automatically included in the classpath.
Here are the steps:
1) Close the TEP client
2) Download the official Xerces2 (BINARY) from
http://xerces.apache.org/mirrors.cgi
e.g. Xerces2 Java 2.9.1 - zip
3) From this zip (or tar.gz), extract the two following JAR files:
xercesImpl.jar
xml-apis.jar
4) Copy these two files to the following directory:
<SUN_JVM_HOME>\lib\ext
e.g. (Windows) C:\Program Files\Java\jre6\lib\ext
e.g. (UNIX) /opt/jre6/lib/ext
5) Clear the Sun Java JRE cache.
Note: You will continue to observe the same behavior unless you clear the Java cache.
6) Open the TEP client as usual.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21438274