Question & Answer
Question
How do I setup notifications to show someone in the From User?
Cause
As of release 3.4.2, a new smart section was added to the Notification Business Object and Form to allow a user's email address to be specified in the From User field instead of the system standard email that currently exists.
The smart section is defined against triPeopleLink Business Object. The Notification workflow should be set up so that this section will be populated with the send (From user) information. Also, the email notification will look like it is coming from the user who sent it instead of the TRIRIGA System.
Answer
To implement this feature, you would need to modify any notification workflow that sends an email to populate the sender (From user). The From user is not set by default. To modify your workflow follow the steps below.
- Navigate to Tools > Builder Tools > Workflow Builder
- Select triHelper (Module) and triNotificationHelper (BO)
- Revise workflow "triNotificationHelper - Synchronous - Resolve Notification Content and Send Notification"
- Add a "Retrieve Records" tasks similar to screenshot below
- Add a Modify Records task similar to the screen shot below
- Click on Edit Map action on "Modify Records" task and map the fields similar to screenshot below
- Publish the workflow.
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Document Information
Modified date:
17 June 2018
UID
swg21986899