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Users unable to log into DS Clients receiving error "Failed to create session for user [xxxxx]: The maximum number of sessions has been reached."

Troubleshooting


Problem

DataStage users are unable to log into any of the DS Clients. When they try, they get the error message "Failed to create session for user [xxxxxx]: The maximum number of sessions has been reached." However, if the user is added into the Suite Administrator's group in the IS Web Console, they are able to log in properly.

Symptom

Users without elevated privileges are unable to log in to DataStage via the DS Clients but users with elevated privileges (users in the Suite Administrator's group) are able to log in.

Cause

There are a few possible causes for this error message.

1. WebSphere Application Server has been restarted using the incorrect user account.
Non-root user starting up WAS when it should be root user

2. Websphere Application Server is running with Maintenance Mode = ON
In normal operations, Maintenance Mode should be set to OFF

3. Information Server has been set up so that WAS is running non-root and DataStage also running as non-root. WAS was started as non-root user, but DataStage was started as root user.

4. There are many leftover sessions remaining which were not cleaned up properly after an exit or disconnection of the DS Clients.

Diagnosing The Problem

To diagnose the issue, the following checks should be done:

1. Check if WAS and DataStage has been started using their respectively correct user account.
Run ' ps -ef | grep java' to check the owner of the WAS java process
Run 'ps -ef | grep dsr' to check the owner of the dsrpcd process

2. Check what is the state of WAS' Maintenance Mode
Run .'./ASBServer/bin/SessionAdmin.sh -user <isadmin> -password <password> -get-maint-mode'
This will display what is the current state of WAS' Maintenance Mode

3. Log into the IS Web Console.
Then browse to the "Administration" tab -> Session Management -> Active Sessions and check how many sessions are still active.

Resolving The Problem

1/ If the user account that started the WAS java and dsrpcd processes are the correct ones. If Information Server has been set up to use non-root for WAS and DataStage and these processes should be started by non-root users. If Information Server has been set up to use root (this is the default method), then these processes should be started by the root user.

2. If running SessionAdmin.sh reveals that WAS is running with Maintenance Mode = ON, it needs to be switched off.
Run "../ASBServer/bin/SessionAdmin.sh -user <isadmin> -password <password> -set-maint-mode OFF".
Then run the "./SessionAdmin.sh -user <isadmin> -password <password> -get-maint-mode" to check that the Maintenance Mode has been switched to OFF.
(You can run SessionAdmin.sh with the '-help' option to get more information on the available command options).

3/ If there are lots of sessions as viewed in the IS Web Console, please do a cleanup of sessions that are no longer needed to pare down the list of connected sessions.

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Document Information

Modified date:
16 June 2018

UID

swg21609527