Troubleshooting
Problem
Attempts to login through LDAP with case in-sensitive username in IBM Sterling Order Management leads to Invalid Login error.
Cause
loginID field is case sensitive in sterling
Diagnosing The Problem
When the implementor class returns success, Sterling tries to login with the loginID that is entered and it fails if the user has entered the login ID in different case,
For Example:
In Active Directory if the user id is as 'alpha' and sterling DB also has user as 'alpha', If user enters the value as 'Alpha' though Active Directory authenticates, Sterling declines the login.
NOTE:: Active Directory(AD) serves as a database where the user details are stored, and LDAP is one of the protocols which makes use of the AD.
Resolving The Problem
From products perspective,the login credentials are case sensitive hence it will not allow if there is mismatch in the alphabets case as well for the login credentials.
Workaround:
- Ensure when the data comes from LDAP to sterling, the login credentials are exchanged with the case of alphabets as that is stored in the sterling DB
OR
- Ensure the case for the login credentials are passed same as the one that are stored in sterling.
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Document Information
Modified date:
16 June 2018
UID
swg21976988