Troubleshooting
Problem
User clicks "Maintain - User - Rights". An error appears. If they then click on any user's name, then the CAM user ID is empty (blank). New CAM users cannot be added/edited.
Symptom
The user currently logged in is not authorized to use this method
Cause
There are other possible causes for this message.
- TIP: See separate IBM Technote #1371155 for more examples.
This Technote specifically relates to the scenario where the cause is that both of the following are correct:
- the 'Allow Anonymous Access' setting (in Cognos Configuration) is configured to be FALSE
- However, Controller is set to use Native authentication.
- In other words, Controller is not configured to use Cognos CAM authentication.
Resolving The Problem
When Controller uses Native security, then the setting 'Allow Anonymous Access' should be TRUE.
Steps:
1. Obtain some downtime (no users in the system)
2. Logon to the Controller application server
3. Launch 'Cognos Configuration'
4. Navigate to the section "Security > Authentication > Cognos"
5. Assuming you are not planning to use Active Directory, set Allow Anonymous Access to TRUE.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21427502