IBM Support

Use defined groups option in the Groups preference setting of CCRC can cause permission denied at login

Troubleshooting


Problem

This technote identifies an issue that can occur in IBM Rational ClearCase Remote Client (CCRC) where login attempts fail with error, Incorrect user name or password. Please try again, when the Use defined groups option is selected in the Groups Preference.

Symptom

Login from CCRC when using a "Use defined groups" user account reports error:

Login to ClearCase                                              
   Incorrect user name or password.  Please try again

Cause


This issue has been identified as a product defect under APAR PK99372.

Environment


This issue has been seen in the following environment:

Windows: ClearCase 7.1.0.2 CCRC Client and Eclipse 3.4.2 with CCRC Plugin

SuSE 9: ClearCase 7.1.0.2 Change Management (CM) Server and VOB server

Diagnosing The Problem


To Reproduce:

1) Create 75 Groups and then create a user who belongs to the newly created 75:

    groupadd -g 8000 g8000                                          
    groupadd -g 8001 g8001                                          
    .                                                              
    .                                                              
    groupadd -g 8075 g8074                                          
    groupadd -g 8075 g8075                                          
                                                                   
    useradd -d /home/saturn -g 8000 -G 8000,8001,8002,8003,8004,8005
    ,8006,8007,8008,8009,8010,8011,8012,8013,8014,8015,8016,8017,801
    8,8019,8020,8021,8022,8023,8024,8025,8026,8027,8028,8029,8030,80
    31,8032,8033,8034,8035,8036,8037,8038,8039,8040,8041,8042,8043,8
    044,8045,8046,8047,8048,8049,8050,8051,8052,8053,8054,8055,8056,
    8057,8058,8059,8060,8061,8062,8063,8064,8065,8066,8067,8068,8069
    ,8070,8071,8072,8073,8074,8075 -u 8000 saturn                  


2) Login to either the CCRC Client or Eclipse with the CCRC Plugin: You are successful.
3) Goto Window -Preferences -ClearCase Remote Client -Groups, and click "Use defined groups" and specify a new ClearCase Primary Group from the list of 75 and add several (no more than 16) Additional ClearCase Groups

4) Close out of CCRC or Eclipse, restart, and then try to login

Resolving The Problem



The defect has been resolved in ClearCase 7.0.1.8 and 7.1.1.1.

WORKAROUND

Set the Groups preference to "Use default".

  1. Goto Window > Preferences
  2. Expand ClearCase Remote Client
  3. Click Groups
  4. Click "Use Default"
  5. Close and reopen CCRC / Eclipse





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Document Information

Modified date:
29 September 2018

UID

swg21413165