IBM Support

Upgrading ClearQuest Full-Text Search from ClearQuest 8.0.0.1 to 8.0.0.2 will stop ClearQuest Web Full-Text Search from working

Troubleshooting


Problem

If you have deployed ClearQuest Full-Text Search and you are upgrading from ClearQuest 8.0.0.1 to 8.0.0.2, the restore step of the upgrade process will fail to properly reset the value of FTS_HOME. As a result, if you try to use ClearQuest Full-Text Search from ClearQuest Web, you will get the following error: > Error from RPC server: Internal Error: CRMTS0007E An unknown error occurred during full-text search execution. > Contact your ClearQuest administrator to verify that the search engine sever is properly configured and running. Or: > Error from RPC server: Internal Error: execute_fulltext_search: Unexpected Exception

Symptom

Using the ClearQuest Full-Text Search Administrator tool (FTSA), when you issue the command "--restore_was_profiles" to restore your existing ClearQuest Full-Text Search deployments, the command will report the following:

    Info : ====> Restore CQ FTS WAS Profiles from backup data... START
    Info : Restoring CQ FTS WAS Profiles from: C:/CQFTS.Restore/'
    Info : Restoring CQ FTS WAS profile: C:/CQFTS.Restore/cqfts_TextSearch_SAMPL/cqfts_TextSearch_SAMPL.txt'
    Warn : *********vvvvvv IGNORING POSSIBLY SAFE ERROR vvvvvv*********
    Cannot gather CQ FTS WAS profile data: C:/CQFTS.Profiles/TextSearch_SAMPL/, cqfts_TextSearch_SAMPL, 14080, , C:/CQFTS.Profiles/TextSearch_SAMPL/cqfts_TextSearch_SAMPL/config/cells/dfltCell/nodes/cqfts_TextSearch_SAMPL/servers/server1/server.xml, manual
    Warn : *********ˆˆˆˆˆˆ IGNORING POSSIBLY SAFE ERROR ˆˆˆˆˆˆ*********
    Info : ====> Restore CQ FTS WAS Profiles from backup data... DONE
    Info :
    Info : ************************************************************
    Info : See the file 'C:/CQFTS.Search/TextSearch_SAMPL/AboutThisFTS.txt'
    Info : For important notes.
    Info : ************************************************************
    Info :
    Info : Log ended on -> Thu Mar 13 12:51:49 2012

This warning means your restore was successful, however the restored WebSphere profile in which ClearQuest Full-Text Search runs is not properly set.

Cause

There is a known defect in the ClearQuest 8.0.0.1 Full-Text Search Administration tool where, during the step of "--prep_upgd_was_profiles", it does not capture the current FTS_HOME location. As a result, when you issue the command "--restore_was_profiles", FTS_HOME is not properly set and the WebSphere profile for ClearQuest Full-Text Search fails to start.

Resolving The Problem

To resolve this issue, when "--restore_was_profiles" has completed, issue the following command using the ClearQuest Full-Text Search Administration tool:

    cqperl cqtsadmin.pl --username admin --password "" --dbset TextSearch --userdb SAMPL --ftshome C:\CQFTS.Search --set_solr_home --stop_fts_was_profile --start_fts_was_profile

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Full-Text Search","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.0.0.1;8.0.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21587173