IBM Support

The upgrade_7x.bat script does not run for the IBM Business Process Manager (BPM) and a password failure message is seen

Troubleshooting


Problem

When you use the upgrade_7x.bat command, you receive a password failure message and cannot upgrade the product.

Symptom

Text that is similar to the following messages is seen:

com.lombardisoftware.tools.dbupgrade.UpgradeDatabase - Could not connect to your Process Server database.
java.lang.RuntimeException: Could not connect to your Process Server database.                                                              
at com.lombardisoftware.tools.dbupgrade.steps.TestDatabases.execute    
(TestDatabases.java:33)                                                
at com.lombardisoftware.tools.dbupgrade.UpgradeDatabase.main          
(UpgradeDatabase.java:179)                                          
Caused by: com.ibm.db2.jcc.am.SqlInvalidAuthorizationSpecException:    
[jcc][t4][2013][11249][3.61.65] Connection authorization failure occurred.  Reason: User ID or Password invalid. ERRORCODE=-4214, SQLSTATE=28000

Cause

This issue occurs because the db2 design file properties are incorrect.

Environment

This issue has been seen in a Windows Server 2008 R2 cluster environment.

Resolving The Problem

To resolve this problem, verify that the databaseUser value in the db2 design file is correct. For example, the file name might be bpm.standard.standalone.dbDesign or bpm.standard.nd.dbDesign

If the databaseUser value is not correct, see the Changing the database information for Process Server and the Performance Data Warehouse for the IBM Business Process Manager (BPM) products document to modify the db2 design file. The end of the document lists the steps to change the database design file.

[{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTBX","label":"IBM Business Process Manager Express"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21607400