IBM Support

Unsupported key table format version number while adding key to keytab

Troubleshooting


Problem

when ading a key to hte keytab file with the kadmin, a error could be encountered: Unsupported key table format version number while adding key to keytab

Symptom

error returned - Unsupported key table format version number while adding key to keytab

Cause

local file to which you want to export the key (/etc/krb5.keytab) is in an incorrect format.
This is usually because you have tried to create an empty file (using touch or similar commands) beforehand, and then export the key into it.

Diagnosing The Problem

To verify that this is indeed the case, try running kliston the existing file to which you are attempting to export the key:
example:
sudo klist -k /etc/keytab

klist: Unsupported key table format version number while starting keytab scan

Resolving The Problem

This usually happens when the local file to which you want to export the key (/etc/krb5.keytab) is in an incorrect format. The most common reason why this would happen is if you have tried to create an empty file (using touch or similar commands) beforehand, and then export the key into it.

To verify that this is indeed the case, try running kliston the existing file to which you are attempting to export the key:
sudo klist -k /etc/keytab

klist: Unsupported key table format version number while starting keytab scan

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
IBM PureData System

Software version:
1.0.0

Document number:
545255

Modified date:
17 October 2019

UID

swg21979193