IBM Support

"UnsatisfiedLinkError: org/eclipse/swt/internal/C.PTR_sizeof()" and "Internal Error ... java.lang.NullPointerException: Can not set current context to null" errors when clicking JAVA menus (example 'Intercompany Report'), caused by Appsense

Troubleshooting


Problem

User clicks 'Company - Reports - Intercompany Report'. An error appears.
 - A similar error appears if the user clicks 'Group- Reports - Intercompany Report'.
Errors also occur using other Java based functionality.

Symptom

Group - Reports - Intercompany Report:
image-20190301072245-1
UnsatisfiedLinkError: org/eclipse/swt/internal/C.PTR_sizeof()
    
'Maintain - Jobs - Define':
image-20190301072458-3
Internal Error
com.ibm.cognos.ccr.integration.FatalIntegrationException: Failed to invoke method loadDataForView
    at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter.internalInvoke(IntegrationServiceAdapter.java:265)
    at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter.invoke(IntegrationServiceAdapter.java:243)
    at com.ibm.cognos.ccr.integration.ServiceCommand.loadData(ServiceCommand.java:196)
    at com.ibm.cognos.ccr.integration.ServiceCommand.doExecute(ServiceCommand.java:185)
    at com.ibm.cognos.ccr.integration.ServiceCommand$MyRunnable.run(ServiceCommand.java:47)
    at java.lang.Thread.run(Thread.java:811)
Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
    at java.lang.reflect.Method.invoke(Method.java:508)
    at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter.internalInvoke(IntegrationServiceAdapter.java:262)
    ... 5 more
Caused by: java.lang.NullPointerException: Can not set current context to null
    at com.ibm.cognos.ccr.common.DefaultModelContext.setCurrentThreadContext(Unknown Source)
    at com.ibm.cognos.ccr.common.DefaultModelContext.setCurrentThreadContext(Unknown Source)
    at com.ibm.cognos.ccr.integration.application.internal.IntegrationServiceImpl.initializeModelContext(Unknown Source)
    at com.ibm.cognos.ccr.integration.application.internal.IntegrationServiceImpl.loadDataForView(Unknown Source)
    ... 10 more
Define Business Rules:
image-20190301072630-4

Cause

Third-party 'AppSense' tool (running on the Citrix server) was blocking the launching of a required DLL file (necessary for the IBM Cognos Controller CCR.EXE client to run its Java components).

Environment

Problem does not affect all client devices.
Example:
In one real-life customer example:
  • Everything works OK when the IBM Cognos Controller client is launched/run directly on the IBM Cognos Controller application server
  • The problem only affected users running the IBM Cognos Controller client on a Citrix server (where third-party tool 'AppSense' was running).

Diagnosing The Problem

Resolving The Problem

Either:
  • Disable the use of AppSense (on the Citrix server)
  • or reconfigure AppSense to allow required DLL file
Note.  In one real-life customer scenario, the following DLL (found in the user profile) needed to be excluded from the AppSense security policy:
%USERPROFILE%\ccr-config\.eclipse\configuration\org.eclipse.osgi\92\0\.cp\swt-win32-4530.dll

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 July 2021

UID

ibm10874514