Troubleshooting
Problem
You attempt to log into your i2 iBase database but receive an error and you cannot log in.
Symptom
You receive an error message which includes Unrecognized Database Format '\\servername\sharename\xxxx.ids' when trying to log into your iBase security file (.ids file).
Cause
The ids (security) file has become corrupt; iBase does not see it a compatible file and cannot therefore open it.
Environment
This issue affects iBase security (.ids) files that have not been upsized to MS SQL Server but are instead in the MS Jet\Access format.
Diagnosing The Problem
Try logging into your iBase database and if you are unsuccessful and receive an error that includes 'Unrecognised Database Format' and a file path ending in .ids then you have a corrupted security (.ids) file. The file is effectively broken at this stage.
Resolving The Problem
1) Obtain a backup of the affected iBase security (.ids) file from just before the database was last accessible.
2) Ask any remaining users still in the database to close down iBase, to guarantee they are out of both the database and the security file (ids). We have seen instances where users who were in the database prior to the corruption could still work in the database, even though users trying to log in once the file is corrupted were unsuccessful.
3) Paste in your backup iBase.ids and ask your users to try logging in again.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
26 September 2019
UID
ibm11075275